Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 617559 - IR receiver cannot wake machine
IR receiver cannot wake machine
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 613401 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 08:35 EDT by Pierre Ossman
Modified: 2010-09-13 22:47 EDT (History)
9 users (show)

See Also:
Fixed In Version: kernel-2.6.33.8-149.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 18:08:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2010-07-23 08:35:23 EDT
I have a Microsoft/Philips IR remote receiver hooked up to my machine and it has the functionality to wake the machine out of suspend. This is fairly important feature when using the machine as a HTPC. Unfortunately something is buggy in the F13 kernel so it's not working properly. It seems to be fixed upstream though as I've been messing with some graphics issues and have therefore tried drm-next. With that kernel, the receiver can properly wake the machine.

To enable wakeup I'm doing this from sleep.d:

		for node in /sys/bus/usb/devices/*/power/wakeup; do
			echo enabled > $node
		done

The proper power/wakeup node exists on both kernels and doing a cat on it shows that it has accepted the "enabled" value. The system behaves as if I never enabled the device though.

Since it is fixed upstream, I'm hoping there is some ACPI fix that can be backported.
Comment 1 Chuck Ebbert 2010-07-23 13:05:49 EDT
Can you try kernel-2.6.34.1-29.fc13 from koji? It has backports of the ACPI GPE fixes from 2.6.35-rc in it.
Comment 2 Pierre Ossman 2010-07-24 12:14:34 EDT
Unfortunately not, because of bug 617561.
Comment 3 Pierre Ossman 2010-07-24 13:57:24 EDT
(With the "nomodeset" test in bug 617561, the machine still didn't resume when triggered by the remote)
Comment 4 Pierre Ossman 2010-07-24 14:09:47 EDT
Need to do a correction above. drm-next seems to be based on 2.6.35-rc5, not 2.6.34-rc5. I got confused by the git-describe tag: v2.6.34-rc5-10857-g7d8d9ac.
Comment 5 Pierre Ossman 2010-07-24 16:33:12 EDT
FYI, vanilla 2.6.34 has the bug and vanilla 2.6.35-rc5 doesn't. Fedora lirc patch applied in both cases.
Comment 6 Pierre Ossman 2010-07-24 18:29:21 EDT
I've been testing kernels and whatever fixed this was introduced between rc3 and rc4. I'll see if I can find the exact commit.
Comment 7 Pierre Ossman 2010-07-25 07:47:00 EDT
Bisected and found the commit that makes things work. Fairly obvious when you read the commit message:

commit 48826626263d4a61d06fd8c5805da31f925aefa0
Author: Alan Stern <stern@rowland.harvard.edu>
Date:   Tue Jun 22 16:14:48 2010 -0400

    USB: obey the sysfs power/wakeup setting
    
    This patch (as1403) is a partial reversion of an earlier change
    (commit 5f677f1d45b2bf08085bbba7394392dfa586fa8e "USB: fix remote
    wakeup settings during system sleep").  After hearing from a user, I
    realized that remote wakeup should be enabled during system sleep
    whenever userspace allows it, and not only if a driver requests it
    too.
    
    Indeed, there could be a device with no driver, that does nothing but
    generate a wakeup request when the user presses a button.  Such a
    device should be allowed to do its job.
    
    The problem fixed by the earlier patch -- device generating a wakeup
    request for no reason, causing system suspend to abort -- was also
    addressed by a later patch ("USB: don't enable remote wakeup by
    default", accepted but not yet merged into mainline).  The device
    won't be able to generate the bogus wakeup requests because it will be
    disabled for remote wakeup by default.  Hence this reversion will not
    re-introduce any old problems.
    
    Signed-off-by: Alan Stern <stern@rowland.harvard.edu>
    Cc: stable <stable@kernel.org> [.34]
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

Backport, pretty please? :)
Comment 8 Chuck Ebbert 2010-07-25 16:27:54 EDT
2.6.3[23] backport of that patch is here:

  http://www.spinics.net/lists/linux-usb/msg33736.html
Comment 9 Pierre Ossman 2010-07-25 17:34:28 EDT
Awesome. Should be harmless enough to be put into the Fedora 13 kernel I hope? :)
Comment 10 Chuck Ebbert 2010-07-26 14:39:01 EDT
Fixed in 2.6.32.16-152.fc12 and 2.6.34.1-30.fc13
Comment 11 Fedora Update System 2010-08-07 01:00:44 EDT
kernel-2.6.34.2-34.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.34.2-34.fc13
Comment 12 Fedora Update System 2010-08-07 19:28:42 EDT
kernel-2.6.34.2-34.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.34.2-34.fc13
Comment 13 Fedora Update System 2010-08-10 19:53:44 EDT
kernel-2.6.34.3-37.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.34.3-37.fc13
Comment 14 Fedora Update System 2010-08-11 03:26:04 EDT
kernel-2.6.34.3-37.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.34.3-37.fc13
Comment 15 Chuck Ebbert 2010-08-18 05:42:58 EDT
2.6.34 kernel has been withdrawn. This will be fixed in a 2.6.33 update kernel.
Comment 16 Fedora Update System 2010-08-18 06:19:07 EDT
kernel-2.6.33.8-149.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.33.8-149.fc13
Comment 17 Pierre Ossman 2010-08-18 16:44:13 EDT
Confirmed working with 2.6.33.8-149.fc13.x86_64. Thank you for including this.
Comment 18 Fedora Update System 2010-08-19 21:26:18 EDT
kernel-2.6.33.8-149.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.33.8-149.fc13
Comment 19 Fedora Update System 2010-08-23 18:08:35 EDT
kernel-2.6.33.8-149.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Chuck Ebbert 2010-08-28 19:30:15 EDT
*** Bug 613401 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.