Bug 613502 - RFE: Publican Website - Default Bookmarkable Machine Generated Product/Version Level Index Pages
Summary: RFE: Publican Website - Default Bookmarkable Machine Generated Product/Versio...
Status: CLOSED ERRATA
Alias: None
Product: Publican
Classification: Community
Component: publican   
(Show other bugs)
Version: 1.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn ๐Ÿž
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 626438 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-12 03:45 UTC by Michael Hideo
Modified: 2010-11-24 04:20 UTC (History)
5 users (show)

Fixed In Version: publican-2.2-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 20:42:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Hideo 2010-07-12 03:45:57 UTC
Description of problem:

In the current version of the publican website there is no per product/version bookmarkable index. For example, I want to pass a specific link of the "Fedora 12 - Japanese Documentation" or a specific link to the "Red Hat Enterprise Linux 5  - German documentation.


Additional info:

Could this be split into 2 parts:

1. A bookmarkable per-product link that explodes the navigation tree and automatically generates a page with the linked title names and version numbers. This would be per language. With the name of each book is a description from the abstract field. 

2. A bookmarkable per-product and per-version link that explodes the navigation tree and automatically generates a page with the linked title names. With the name of each book is a description from the abstract field.

Comment 1 Jeff Fearn ๐Ÿž 2010-07-27 04:49:03 UTC
When we designed this ... aeons ago ... you said some day you wanted to add product/version splash pages with blurbs about the product and version. Did you forget this or did the goal posts move?

Comment 7 Jeff Fearn ๐Ÿž 2010-08-23 23:59:43 UTC
*** Bug 626438 has been marked as a duplicate of this bug. ***

Comment 11 Jeff Fearn ๐Ÿž 2010-09-21 03:39:06 UTC
Added web_type parameter to control special pages, home, product, version.

Added code to pop menu open to current page (requires books to be rebuilt to become active on a page).

Added icon to menu for products/versions with splash pages, to allow navigation from the menu.

Fixed in build: 2.1-0%{?dist}.t74

Comment 12 Fedora Update System 2010-10-06 05:49:14 UTC
publican-2.2-0.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc13

Comment 13 Fedora Update System 2010-10-06 05:50:29 UTC
publican-2.2-0.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc12

Comment 14 Fedora Update System 2010-10-06 05:50:33 UTC
publican-2.2-0.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc14

Comment 15 Fedora Update System 2010-10-08 20:40:38 UTC
publican-2.2-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.