Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613610 - AttributeError: 'NoneType' object has no attribute 'network'
AttributeError: 'NoneType' object has no attribute 'network'
Status: CLOSED DUPLICATE of bug 613075
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 08:19 EDT by James Laska
Modified: 2013-09-02 02:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 08:31:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (167.78 KB, text/plain)
2010-07-12 08:19 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-07-12 08:19:33 EDT
Created attachment 431157 [details]
anacdump.txt

Description of problem:

Testing install from boot.iso (http://alt.fedoraproject.org/pub/alt/stage/rawhide-testing/x86_64/os/) results in a traceback

Version-Release number of selected component (if applicable):
 * anaconda-14.10

How reproducible:
 * everytime I click "Enable Network"

Steps to Reproduce:
1. Boot the boot.iso
2. Proceed to graphical install, select language and keymap settings
3. Select 'Basic' storage devices
4. Choose all 4 local disks
5. At the hostname screen, select "Enable Network"
  
Actual results:

<report xmlns="http://www.redhat.com/gss/strata"><binding name="localhash">6fce05829417b8502ec360672f5730ab49a4a6bcfb7cc47d882e9385ca12c7cb</binding><binding name="product" /><binding name="description">The following was filed automatically by anaconda:
anaconda 14.10 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/pyanaconda/gui.py", line 903, in enableNetwork
    in self.anaconda.id.network.netdevices.items()
  File "/usr/lib64/python2.6/site-packages/pyanaconda/iw/network_gui.py", line 67, in _setupNetwork
    self.intf.enableNetwork(just_setup=True)
AttributeError: 'NoneType' object has no attribute 'network'
</binding><binding fileName="/tmp/anaconda-tb-C9U8fa" name="pythonUnhandledException" type="text">anaconda 14.10 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/pyanaconda/gui.py", line 903, in enableNetwork
    in self.anaconda.id.network.netdevices.items()
  File "/usr/lib64/python2.6/site-packages/pyanaconda/iw/network_gui.py", line 67, in _setupNetwork
    self.intf.enableNetwork(just_setup=True)
AttributeError: 'NoneType' object has no attribute 'network'

Local variables in innermost frame:
_[1]: []
self: &lt;pyanaconda.gui.InstallInterface object at 0x7fdfbdbada90&gt;
just_setup: True

Expected results:

No traceback

Additional info:
Comment 1 Radek Vykydal 2010-07-12 08:31:44 EDT

*** This bug has been marked as a duplicate of bug 613075 ***

Note You need to log in before you can comment on or make changes to this bug.