Bug 613075 - AttributeError: 'NoneType' object has no attribute 'network'
Summary: AttributeError: 'NoneType' object has no attribute 'network'
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 613610 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-09 16:07 UTC by John Reiser
Modified: 2010-07-12 13:38 UTC (History)
4 users (show)

Fixed In Version: anaconda-14.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-09 17:12:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback and debug info from anaconda (384.01 KB, text/plain)
2010-07-09 16:07 UTC, John Reiser
no flags Details

Description John Reiser 2010-07-09 16:07:51 UTC
Created attachment 430711 [details]
traceback and debug info from anaconda

Description of problem: Anaconda fails with traceback.  During fresh install from DVD, click "Configure network" button on dialog screen for hostname.


Version-Release number of selected component (if applicable):
anaconda-14.10

How reproducible: every time.


Steps to Reproduce:
1. Fresh install from DVD, rawhide of 2010-07-09 (Friday), Basic disks, Custom layout.
2. Click "Configure network" button on dialog screen for hostname.
3.
  
Actual results:
anaconda 14.10 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/pyanaconda/gui.py", line 903, in enableNetwork
    in self.anaconda.id.network.netdevices.items()
  File "/usr/lib64/python2.6/site-packages/pyanaconda/iw/network_gui.py", line 67, in _setupNetwork
    self.intf.enableNetwork(just_setup=True)
AttributeError: 'NoneType' object has no attribute 'network'


Expected results: no traceback


Additional info:

Comment 1 Radek Vykydal 2010-07-12 12:31:44 UTC
*** Bug 613610 has been marked as a duplicate of this bug. ***

Comment 2 James Laska 2010-07-12 12:53:28 UTC
John, were you creating your own Fedora install DVD when hitting this failure?

Updates image available if desired (http://jlaska.fedorapeople.org/updates/613075.img)

Comment 3 John Reiser 2010-07-12 13:27:39 UTC
Thank you for responding, James.  Yes, I create my own DVDs from rawhide using pungi.  I cache the .rpm that pungi uses directly, but I endure the non-caching of anaconda's separate buildinstall repo.  [My network connection is 12Mbit/s.]  I have been frustrated by a sequence of bugs that have prevented getting a complete install from DVD: bug 609247 (pungi), bug 609596 (anaconda), bug 610076 (ati driver), this bug 613075 (anaconda).  Getting AttributeError is especially irksome because I lose time due to something which ought to be checked mechanically.

I will try the 613075.img update.

Comment 4 James Laska 2010-07-12 13:38:45 UTC
(In reply to comment #3)
> I will try the 613075.img update.    

Heads up ... using the updates.img, I then run into bug#613623


Note You need to log in before you can comment on or make changes to this bug.