Bug 613929 - Cannot install RHEL6 via TFTP netboot using ppc64.img
Cannot install RHEL6 via TFTP netboot using ppc64.img
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yaboot (Show other bugs)
6.0
ppc64 Linux
high Severity high
: rc
: 6.0
Assigned To: Roman Rakus
Release Test Team
: Documentation, RHELNAK
Depends On: 591507
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 05:42 EDT by Frank Danapfel
Modified: 2014-01-12 19:12 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The kernel image provided on the CD/DVD is too large for Open Firmware. Consequently, on the POWER architecture, directly booting the kernel image over a network from the CD/DVD is not possible. Instead, use yaboot to boot from a network.
Story Points: ---
Clone Of: 591507
Environment:
Last Closed: 2010-08-17 16:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Frank Danapfel 2010-07-13 05:50:00 EDT
Since the original bug report got closed because it was assigned to the wrong component, I've decided to clone it as a new bug because the IBM team at SAP reported the same issue when trying to test the RHEL 6 Beta2.

The issue seems to be that TFTP can only handle files with a size of up to 32MB, but the /netboot/ppc64.img on the installation ISO has a size of 34MB.

I've also added the "Regression" Keyword, since this method of starting a RHEL installation on a PPC LPAR used to work with RHEL 5 (due to the smaller size of the /netboot/ppc64.img). 

If "distribution is the wrong component for reporting issues with the ppc64.img, please assign it to the correct component and not just close the bug as it happened before.

Frank
Comment 10 Roman Rakus 2010-07-20 09:00:35 EDT
Frank, is it the the whole log? Isn't the output somehow trimmed (the width of the console)? The machine is stuck right after the "2 " is displayed?

If the machine is stuck, the problem is somewhere in the Open Firmware.
On machine I have tried right now, OF displays me 1, 2, 3 numbers and !EA017021 ! and then yaboot continues to work.
Comment 11 Frank Danapfel 2010-07-20 09:38:28 EDT
Roman, yes this is the whole log I received.

I've added the colleague from IBM who was testing this as CC to this BZ, so maybe he can provide some more information.
Comment 12 Frank Danapfel 2010-07-20 09:40:25 EDT
Elmar, can you provide some more information about the problems you encountered when trying to install the RHEL 6 Beta using yaboot?
Comment 19 RHEL Product and Program Management 2010-07-30 18:07:41 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 20 christoph.buchmann 2010-07-31 16:14:34 EDT
So what do you propose that I tell my customers? Go and change your NIM infrastructure or go and buy SLES for a proper LAN-installation?
Comment 21 Roman Rakus 2010-08-02 08:14:51 EDT
LAN installation is working with the yaboot. But not the direct boot of ppc64.img, because the image is too large.
Comment 22 Roman Rakus 2010-08-02 08:24:08 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Network installation was working using RHEL-6 installation CDs/DVD - direct boot of kernel image. This does not work any more, because the kernel image is too large for Open Firmware. Users should use yaboot to boot from network.
Comment 23 Roman Rakus 2010-08-06 10:31:31 EDT
There is newer yaboot built - yaboot-1.3.14-35.el6. Can you please try it?
Comment 27 Elmar Billen 2010-08-11 03:59:12 EDT
(In reply to comment #23)
> There is newer yaboot built - yaboot-1.3.14-35.el6. Can you please try it?    

Where can I get the newer yaboot build?

Can you provide me with a link to some documentation, how a proper yaboot-configuration should look like? Or could you provide a working example of a yaboot.conf which I can adapt to our installation framework here?

Thanks & regards,
 Elmar.
Comment 29 Roman Rakus 2010-08-11 09:08:10 EDT
(In reply to comment #27)
> (In reply to comment #23)
> > There is newer yaboot built - yaboot-1.3.14-35.el6. Can you please try it?    
> 
> Where can I get the newer yaboot build?
It will be in some compose soon.

> 
> Can you provide me with a link to some documentation, how a proper
> yaboot-configuration should look like? Or could you provide a working example
> of a yaboot.conf which I can adapt to our installation framework here?
> 
I just know about the cobbler wiki: https://fedorahosted.org/cobbler/wiki/PowerPc

There is nothing special in yaboot.conf.

> Thanks & regards,
>  Elmar.
Comment 33 Roman Rakus 2010-08-12 05:10:39 EDT
You can get the latest yaboot from http://rrakus.fedorapeople.org/yaboot-1.3.14-35.el6.ppc.rpm
Comment 35 Roman Rakus 2010-08-12 05:18:20 EDT
Another page with some docs about how to netboot PowerPC with yaboot:
http://penguinppc.org/~hollisb/linux/rs6k-netboot.shtml

Hopefully it helps.
Comment 36 Frank Danapfel 2010-08-12 07:51:57 EDT
I think something like the following would be useful to have in the RHEL6 PPC documentation:

http://lists.debian.org/debian-powerpc/2000/03/msg00190.html
Comment 38 RHEL Product and Program Management 2010-08-12 08:18:31 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 42 Ryan Lerch 2010-09-28 23:15:35 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Network installation was working using RHEL-6 installation CDs/DVD - direct boot of kernel image. This does not work any more, because the kernel image is too large for Open Firmware. Users should use yaboot to boot from network.+The kernel image provided on the CD/DVD is too large for Open Firmware.  Consequently, on the POWER architecture, directly booting the kernel image over a network from the CD/DVD is not possible. Instead, use yaboot to boot from a network.

Note You need to log in before you can comment on or make changes to this bug.