This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 614063 - savers/gste-slideshow.c (get_pixbuf_from_local_dir) Check for an empty file list.
savers/gste-slideshow.c (get_pixbuf_from_local_dir) Check for an empty file...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-screensaver (Show other bugs)
5.5
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Patch, Reopened, ZStream
: 526210 (view as bug list)
Depends On:
Blocks: 554476 673990
  Show dependency treegraph
 
Reported: 2010-07-13 11:46 EDT by ritz
Modified: 2014-10-14 12:58 EDT (History)
16 users (show)

See Also:
Fixed In Version: gnome-screensaver-2.16.1-11.el5
Doc Type: Bug Fix
Doc Text:
Previously, using the "Pictures folder" screen saver with an empty Pictures directory could cause the gnome-screensaver program to terminate unexpectedly. This update applies an upstream patch that resolves this issue, and an empty Pictures directory no longer causes the "Pictures folder" screen saver to crash.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 11:54:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch based on upstream (944 bytes, patch)
2010-07-13 11:46 EDT, ritz
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 46781 None None None Never

  None (edit)
Description ritz 2010-07-13 11:46:17 EDT
Created attachment 431497 [details]
patch based on upstream

Description of problem:
gnome-screensaver crashes 

Version-Release number of selected component (if applicable):
gnome-screensaver-2.16.1-8.el5.x86_64

How reproducible:
random

Steps to Reproduce:
1. Empty Pictures folder should probably trigger this.

  
Actual results:
crash

Expected results:
should not crash

Additional notes:
savers/gste-slideshow.c (get_pixbuf_from_local_dir):
Check for an empty file list.  Fixes gnome bz#382757
Comment 1 ritz 2010-07-22 01:04:30 EDT
*** Bug 526210 has been marked as a duplicate of this bug. ***
Comment 15 Ray Strode [halfline] 2012-08-10 11:38:42 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, using the "Pictures folder" screen saver with an empty Pictures directory could cause the gnome-screensaver program to terminate unexpectedly. This update applies an upstream patch that resolves this issue, and an empty Pictures directory no longer causes the "Pictures folder" screen saver to crash.

Note You need to log in before you can comment on or make changes to this bug.