Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614124 - [RFE] have cman print expected failure detection time based upon heuristics
[RFE] have cman print expected failure detection time based upon heuristics
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: FutureFeature
: 614128 (view as bug list)
Depends On: 614128
Blocks: 655920 693781
  Show dependency treegraph
 
Reported: 2010-07-13 13:46 EDT by Steven Dake
Modified: 2016-04-26 10:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 13:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2010-07-13 13:46:00 EDT
Currently our users don't know what to expect the failure between config changes should be when considering the following factors

multipath configuration
qdisk configuration
totem configuration

Have cman print the expected failure detection time based upon heuristics.
Comment 7 Lon Hohberger 2011-05-31 18:14:31 EDT
The goal here is to have CMAN print out a value after taking in to account all of the various timings on the system.

These timings include (but are not entirely limited to; see other bug):
  * multipath timeout
  * quorum disk timeout
  * cman (totem) timeout

This is done in conjunction with execution of heuristics as part of bug 614128  so setting a dependency.

Effectively, this feature is simply designed to print out a message stating how long, in total, the cluster should take to detect a host has died and initiate recovery.

Currently, most of the timers required are printed in the logs, with no indication of what they actually mean.

So, for example, one might see something like the following in the logs as a consequence of implementing this feature:

   corosync[5597]:   [CMAN  ] CMAN X.Y.Z (built Dec 24 2012 14:08:21) started
   corosync[5597]:   [CMAN  ] Failure recovery initiation time 11.2 seconds

If, you then went over and pulled the plug on a host in the cluster, it should be approximately 11.2 seconds before you see the following message:

   corosync[5597]:   [QUORUM] Members[1]: 1
   corosync[5597]:   [TOTEM ] A processor joined or left the membership and a new membership was formed.
   ...
Comment 9 Lon Hohberger 2011-07-21 10:21:23 EDT
*** Bug 614128 has been marked as a duplicate of this bug. ***
Comment 12 Lon Hohberger 2011-08-08 13:05:10 EDT
Most of the tuning and documentation has been superseded by work here:

https://access.redhat.com/knowledge/techbriefs/how-optimally-configure-quorum-disk-red-hat-enterprise-linux-clustering-and-hig

Note You need to log in before you can comment on or make changes to this bug.