Bug 614244 - Plugin fails
Plugin fails
Status: CLOSED DUPLICATE of bug 598657
Product: Fedora
Classification: Fedora
Component: evolution-remove-duplicates (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 18:36 EDT by Peter L R Smith
Modified: 2010-07-16 06:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 07:15:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter L R Smith 2010-07-13 18:36:12 EDT
On Fedora 13 Linux 2.6.33.6-147.fc13.x86_64, after installation of evolution-remove-duplicates 0.0.0-4.fc12@x86_64 (in fc13 repositories) with evolution 2.3.2-1.fc13@x86_64, the eplugin fails to work.

The plugin is visible in the list of available plugins ("Edit" "Plugins"), but cannot be selected (the tick box remains unselected).

This is a reproducible error even after reinstall


Steps to Reproduce:
1.Install evolution-remove-duplicates
2.Try to select the plugin uder "Edit" "Plugins"
3.Select Fails
4.No option to remove duplicates in right click on a selection of mails
  
Expected results:

Plugin tickbox selectable
Option to remove duplicates present in right click on selectionj of mails


Additional info:

Worked fine on Fedora 12
Comment 1 Michel Alexandre Salim 2010-07-14 07:00:16 EDT
F-13 is the last Fedora release to ship evolution-remove-duplicates -- I've removed it from Rawhide because the changes needed to update it for the next Evolution version is just too much for a package that has not been maintained upstream for a long time.

For F-13, I'll try and fix this, but do be prepared to move to another solution.
Comment 2 Michel Alexandre Salim 2010-07-14 07:15:51 EDT
OK, this cannot be fixed -- I just checked and as it turns out, I disabled evolution-remove-duplicates in F-13 as well as in Rawhide, but unfortunately since F-13 is already out, the package cannot be retracted.

Apologies for the inconvenience.

*** This bug has been marked as a duplicate of bug 598657 ***
Comment 3 Peter L R Smith 2010-07-14 07:19:34 EDT
Thank you for your help.

Can you suggest any other solutions other than change mail client which I do not want to do.

The problem is that duplicate mails always become a problem when I am travelling.  It seems that when changing locations evolution does not recognise that I have already downloaded mails still on the server (not deleted for 7 days) and downloads them again.   This means that sometimes I download the same mail 4 times (departure airport lounge, transit airport lounge, hotel, overseas office).  Is this expected behaviour from evolution or a bug?
Comment 4 Michel Alexandre Salim 2010-07-14 11:25:23 EDT
Ah, you're using POP3. Using IMAP might reduce the problem, but I must admit that part of the reason Evolution is no longer my primary mail client is that its IMAP support was rather weak in the past.

The association between downloaded mail messages and their counterparts on the remote POP3 mailbox really should not be affected by the location from which you connect, so I'd suggest you file a bug against Evolution -- either to the upstream GNOME bugtracker, or the Fedora one. The latter is probably better, it'd be good for the Fedora packagers to be aware of this problem anyway, and they'd likely have connections with upstream developers.
Comment 5 Peter L R Smith 2010-07-14 11:46:36 EDT
Thank you Michael

I use POP3 because we delete mails from our mail server after 7 days.

You mentioned previously that I should be prepared to move to another solution.

Do you have any suggestions?
Comment 6 Michel Alexandre Salim 2010-07-16 06:31:43 EDT
Peter,

If you don't need to integrate with either Exchange or the GNOME address book, then Thunderbird is probably a decent choice. I'd encourage you to first report the duplicate bug against Evolution, and see if it gets fixed -- after all, evolution-remove-duplicates is a band-aid that really should not have been needed in the first place.

Note You need to log in before you can comment on or make changes to this bug.