Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 614263 - Report gives a traceback if it cannot read the specified file
Report gives a traceback if it cannot read the specified file
Status: CLOSED DUPLICATE of bug 614274
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Gavin Romig-Koch
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 20:37 EDT by Scott Dodson
Modified: 2010-07-13 22:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 22:02:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dodson 2010-07-13 20:37:04 EDT
Description of problem:
If the user running report doesn't have read permissions to the specified file it results in a python traceback.

Version-Release number of selected component (if applicable):
0.18-3

  
Actual results:
[sdodson@dhcp242-213 ~]$ report /var/log/abrt.log 
Traceback (most recent call last):
  File "/usr/bin/report", line 149, in <module>
    signature = report.createSimpleFileSignature(opts.filename, isBinary)
  File "/usr/lib64/python2.6/site-packages/report/__init__.py", line 222, in createSimpleFileSignature
    { "simpleFile" : NamedFileSignatureValue(exnFileName, isBinary) }
  File "/usr/lib64/python2.6/site-packages/report/__init__.py", line 121, in __init__
    file(fileLocation).read(1)
IOError: [Errno 13] Permission denied: '/var/log/abrt.log'


Expected results:
Clean error message.

Additional info:
Comment 2 Scott Dodson 2010-07-13 22:02:21 EDT

*** This bug has been marked as a duplicate of bug 614274 ***

Note You need to log in before you can comment on or make changes to this bug.