Bug 614274 - [abrt] report-0.18-3.fc13: __init__.py:121:__init__:IOError: [Errno 13] Permission denied: '/var/log/abrt.log'
Summary: [abrt] report-0.18-3.fc13: __init__.py:121:__init__:IOError: [Errno 13] Permi...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: x86_64 Linux
low
medium
Target Milestone: rc
: ---
Assignee: Gavin Romig-Koch
QA Contact: David Kutálek
URL:
Whiteboard: abrt_hash:643bbbb0
Keywords:
: 614263 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-14 02:01 UTC by Scott Dodson
Modified: 2010-11-10 21:29 UTC (History)
3 users (show)

Fixed In Version: report-0.18-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:29:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (753 bytes, text/plain)
2010-07-14 02:01 UTC, Scott Dodson
no flags Details

Description Scott Dodson 2010-07-14 02:01:25 UTC
abrt version: 1.1.9
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/report /var/log/abrt.log
component: report
executable: /usr/bin/report
kernel: 2.6.32-44.el6.x86_64
package: report-0.18-3.fc13
rating: 4
reason: __init__.py:121:__init__:IOError: [Errno 13] Permission denied: '/var/log/abrt.log'
release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)
time: 1279066338
uid: 500

backtrace
-----
__init__.py:121:__init__:IOError: [Errno 13] Permission denied: '/var/log/abrt.log'

Traceback (most recent call last):
  File "/usr/bin/report", line 149, in <module>
    signature = report.createSimpleFileSignature(opts.filename, isBinary)
  File "/usr/lib64/python2.6/site-packages/report/__init__.py", line 222, in createSimpleFileSignature
    { "simpleFile" : NamedFileSignatureValue(exnFileName, isBinary) }
  File "/usr/lib64/python2.6/site-packages/report/__init__.py", line 121, in __init__
    file(fileLocation).read(1)
IOError: [Errno 13] Permission denied: '/var/log/abrt.log'

Local variables in innermost frame:
fileLocation: '/var/log/abrt.log'
isBinary: True
self: <report.NamedFileSignatureValue instance at 0x2a03440>
fileName: None

How to reproduce
-----
1. Run report against an unreadable file

Comment 1 Scott Dodson 2010-07-14 02:01:27 UTC
Created attachment 431647 [details]
File: backtrace

Comment 2 Scott Dodson 2010-07-14 02:02:21 UTC
*** Bug 614263 has been marked as a duplicate of this bug. ***

Comment 4 Gavin Romig-Koch 2010-07-14 21:29:32 UTC
This is fixed upstream, and can be pushed to RHEL as soon as the blocker is approved.

Comment 7 releng-rhel@redhat.com 2010-11-10 21:29:49 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.