Bug 614376 - gv gives Warning: Missing charsets in String to FontSet conversion
Summary: gv gives Warning: Missing charsets in String to FontSet conversion
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gv   
(Show other bugs)
Version: 12
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-14 10:13 UTC by Roderick Johnstone
Modified: 2010-10-26 15:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-26 15:24:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roderick Johnstone 2010-07-14 10:13:07 UTC
Description of problem:
The most recent update to gv causes it to issue warnings when its run. it seems to work ok though.
linux> gv <any postscript file>
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-efont-biwidth-medium-r-normal--16-*-*-*-*-*-iso10646-1,-gnu-unifont-medium-r-normal--16-*-*-*-*-*-iso10646-1,-adobe-helvetica-medium-r-normal--14-*-*-*-*-*-*-*,-jis-fixed-medium-r-*--16-*-*-*-*-*-jisx0208.1983-0,-*-*-medium-r-*--16-*-*-*-*-*-*-*,*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset


Version-Release number of selected component (if applicable):
gv-3.7.1-1.fc12.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. run gv on any or no file
2.
3.
  
Actual results:
Warning messages appear. File is displayed.

Expected results:
No warning messages. File is displayed.

Additional info:
This was already mentioned in BZ #600926, but that was closed as duplicate because it was not the main bug reported.

Comment 1 Edward Sheldrake 2010-10-26 14:38:38 UTC
I think this is due to the lack of an encodings.dir file - bug #634039

Comment 2 Roderick Johnstone 2010-10-26 15:24:28 UTC
Edward: Very many thanks.

The problem was in one of our local font directories. Your mkfontdir command in  bug #634039 fixed it nicely.

Closing this report.


Note You need to log in before you can comment on or make changes to this bug.