Bug 614577 - installbrand -> install_brand syntax change after rebase in F12?
installbrand -> install_brand syntax change after rebase in F12?
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 15:24 EDT by Steve Bonneville
Modified: 2010-11-23 23:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 19:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Bonneville 2010-07-14 15:24:48 EDT
Description of problem:

Change in CLI syntax from Publican 1.6.3 (publican installbrand) to
Publican 2.1.0 (publican install_brand) broke existing script after
rebase in Fedora 12.  Not that I'm arguing with the syntax change, 
but it was a surprise.

Likely to affect F13 or other distributions where rebase happened.

Version-Release number of selected component (if applicable):
publican-2.1-0.fc12.noarch
Comment 1 Ruediger Landmann 2010-07-14 19:10:43 EDT
Hi Steve --

Sorry for the inconvenience; installbrand was one of a small number of actions that was named inconsistently with other publican actions where words are separated by underscores; we cleaned this up in Publican 2. I think the inconsistency was first pointed up on the Publican mailing list, but if so, I can't seem to find that post now.

Refer to Bug 581090 for the list of actions renamed in Publican 2. 

Cheers
Rudi

Note You need to log in before you can comment on or make changes to this bug.