Bug 614644 - logs errors when 'Should-Start' LSB dependencies don't exist
logs errors when 'Should-Start' LSB dependencies don't exist
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 618316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 17:42 EDT by Bill Nottingham
Modified: 2014-03-16 23:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 22:54:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-07-14 17:42:06 EDT
Description of problem:

Noticed when attempting to debug something else... systemd logs errors when SysV scripts have Should-Start/Should-Stop dependencies on something that isn't installed. It should probably just ignore it.

Version-Release number of selected component (if applicable):

3-3

Additional info:

httpd's a test case.
Comment 1 Michal Schmidt 2010-07-27 07:53:19 EDT
*** Bug 618316 has been marked as a duplicate of this bug. ***
Comment 2 Bug Zapper 2010-07-30 08:35:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Lennart Poettering 2010-08-11 22:54:37 EDT
Fixed now upstream, will be in next upload.

Note You need to log in before you can comment on or make changes to this bug.