Bug 614806 - prelink shifts .bss address by .dynbss breaking gdb
Summary: prelink shifts .bss address by .dynbss breaking gdb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdb
Version: 5.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Kratochvil
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On: 614659
Blocks: 614808
TreeView+ depends on / blocked
 
Reported: 2010-07-15 10:05 UTC by Jan Kratochvil
Modified: 2011-05-13 12:45 UTC (History)
2 users (show)

Fixed In Version: gdb-7.0.1-27.el5
Doc Type: Bug Fix
Doc Text:
GDB displayed invalid content of some variables. Separate debuginfo files installed for executables caused this behavior when the prelink program optimized the executable with copy relocations. With this update, GDB correctly displays the contents of all the variables.
Clone Of: 614659
: 614808 (view as bug list)
Environment:
Last Closed: 2011-01-13 23:55:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0099 normal SHIPPED_LIVE gdb bug fix update 2011-01-12 17:21:16 UTC

Description Jan Kratochvil 2010-07-15 10:05:20 UTC
+++ This bug was initially created as a clone of Bug #614659 +++

there is a regression since gdb-7.0 for a combination of:
 * prelinked
 * main executable
 * using separate debug info
 * using copy relocations

Hopefully it may not affect customer applications but it makes debugging of the RHEL components difficult:

int bssvar, *bssvarp = &bssvar;

(gdb) p &bssvar
$1 = (int *) 0x600b54
(gdb) p bssvarp
$2 = (int *) 0x600b50

Version-Release number of selected component (if applicable):
FAIL gdb-7.1-28.fc13.x86_64
FAIL gdb-7.0.1-24.el5
PASS <= FSF GDB 7.0
FAIL >= FSF GDB 7.1

How reproducible:
Always.

Steps to Reproduce:
Updated gdb.base/prelink.exp testcase.

Fix + testcase:
http://sourceware.org/ml/gdb-patches/2010-07/msg00237.html

Comment 3 Jan Kratochvil 2010-09-06 18:43:22 UTC
* Mon Sep  6 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.1-27.el5
- Fix prelinked executables with sepdebug and copy relocations (BZ 614806).
  - Fix incorrect relocation of sections with duplicate name (BZ 575737).
  - Fix false warning: section .gnu.liblist not found in ...

Comment 7 Eva Kopalova 2010-11-16 17:14:23 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
GDB displayed invalid content of some variables. Separate debuginfo files installed for executables caused this behavior when the prelink program optimized the executable with copy relocations. With this update, GDB correctly displays the contents of all the variables.

Comment 9 errata-xmlrpc 2011-01-13 23:55:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0099.html


Note You need to log in before you can comment on or make changes to this bug.