Bug 614808 - prelink shifts .bss address by .dynbss breaking gdb
Summary: prelink shifts .bss address by .dynbss breaking gdb
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdb
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Kratochvil
QA Contact: Petr Muller
URL:
Whiteboard:
Keywords: Regression
Depends On: 614659 614806
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-15 10:07 UTC by Jan Kratochvil
Modified: 2016-09-20 02:07 UTC (History)
4 users (show)

(edit)
Clone Of: 614806
(edit)
Last Closed: 2010-11-10 20:27:21 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2010-07-15 10:07:19 UTC
+++ This bug was initially created as a clone of Bug #614806 +++

there is a regression since gdb-7.0 for a combination of:
 * prelinked
 * main executable
 * using separate debug info
 * using copy relocations

Hopefully it may not affect customer applications but it makes debugging of the RHEL components difficult:

int bssvar, *bssvarp = &bssvar;

(gdb) p &bssvar
$1 = (int *) 0x600b54
(gdb) p bssvarp
$2 = (int *) 0x600b50

Version-Release number of selected component (if applicable):
FAIL gdb-7.1-28.el6
FAIL gdb-7.1-28.fc13.x86_64
PASS <= FSF GDB 7.0
FAIL >= FSF GDB 7.1

How reproducible:
Always.

Steps to Reproduce:
Updated gdb.base/prelink.exp testcase.

Fix + testcase:
http://sourceware.org/ml/gdb-patches/2010-07/msg00237.html

Comment 3 Petr Muller 2010-08-03 14:39:02 UTC
# runtest --tool=gdb gdb.base/prelink.exp
(...)
                === gdb Summary ===

# of expected passes            4

Comment 4 releng-rhel@redhat.com 2010-11-10 20:27:21 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.