Bug 61511 - incorrect dep listed in UnsolvedDependencyError
incorrect dep listed in UnsolvedDependencyError
Status: CLOSED DUPLICATE of bug 61527
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-20 16:32 EST by James Manning
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-20 17:30:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yes, I *am* lame enough to supply a patch :) (652 bytes, patch)
2002-03-20 16:41 EST, James Manning
no flags Details | Diff

  None (edit)
Description James Manning 2002-03-20 16:32:35 EST
up2date.py, around line 1040 does the raise UnsolvedDependencyError
seen in bugs like bug 61457, but the error string doesn't make sense.

I think (not sure) that the second %s sub should be just dep and notretList[dep].
Checking the loop, since pkgs is retList[dep] from line 1024 and we never modify
either, I think they'd always be the same.
Comment 1 James Manning 2002-03-20 16:41:09 EST
Created attachment 49268 [details]
yes, I *am* lame enough to supply a patch :)
Comment 2 Adrian Likins 2002-03-20 17:30:34 EST
yeah, looks right.

Thanks for the patch.
Comment 3 James Manning 2002-03-20 17:57:47 EST

*** This bug has been marked as a duplicate of 61527 ***

Note You need to log in before you can comment on or make changes to this bug.