Bug 615651 - [abrt] kdeutils-printer-applet-6:4.4.92-1.fc14: posixpath.py:119:dirname:AttributeError: 'QString' object has no attribute 'rfind'
[abrt] kdeutils-printer-applet-6:4.4.92-1.fc14: posixpath.py:119:dirname:Attr...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:354755d4 https://fedoraproj...
: CommonBugs, Patch
: 633951 (view as bug list)
Depends On:
Blocks: kde-4.5
  Show dependency treegraph
 
Reported: 2010-07-17 14:57 EDT by Antonio Trande
Modified: 2010-09-14 14:29 EDT (History)
17 users (show)

See Also:
Fixed In Version: 4.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 10:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (882 bytes, text/plain)
2010-07-17 14:57 EDT, Antonio Trande
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 245289 None None None Never

  None (edit)
Description Antonio Trande 2010-07-17 14:57:04 EDT
abrt version: 1.1.5
architecture: i686
cmdline: python /usr/bin/printer-applet
component: kdeutils
executable: /usr/bin/printer-applet
kernel: 2.6.35-0.41.rc5.git1.fc14.i686
package: kdeutils-printer-applet-6:4.4.92-1.fc14
reason: posixpath.py:119:dirname:AttributeError: 'QString' object has no attribute 'rfind'
release: Fedora release 14 (Rawhide)
time: 1279392903
uid: 500

backtrace
-----
posixpath.py:119:dirname:AttributeError: 'QString' object has no attribute 'rfind'

Traceback (most recent call last):
  File "/usr/bin/printer-applet", line 1163, in <module>
    applet = JobManager()
  File "/usr/bin/printer-applet", line 241, in __init__
    uic.loadUi(APPDIR + '/' + "printer-applet.ui", self.mainWindow)
  File "/usr/lib/python2.6/site-packages/PyQt4/uic/__init__.py", line 177, in loadUi
    return DynamicUILoader().loadUi(uifile, baseinstance)
  File "/usr/lib/python2.6/site-packages/PyQt4/uic/Loader/loader.py", line 24, in loadUi
    return self.parse(filename, os.path.dirname(filename))
  File "/usr/lib/python2.6/posixpath.py", line 119, in dirname
    i = p.rfind('/') + 1
AttributeError: 'QString' object has no attribute 'rfind'

Local variables in innermost frame:
p: PyQt4.QtCore.QString(u'/usr/share/kde4/apps/printer-applet/printer-applet.ui')
Comment 1 Antonio Trande 2010-07-17 14:57:08 EDT
Created attachment 432620 [details]
File: backtrace
Comment 2 Kevin Kofler 2010-07-18 18:27:15 EDT
Pretty obvious what's going wrong here: the kdeutils printer-applet is trying to pass a QString to a function (os.path.dirname) that expects a regular Python string. It needs to be converted to a Python string first.
Comment 3 yesyoucanspamme 2010-07-20 19:08:59 EDT
Package: kdeutils-printer-applet-6:4.4.92-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. Boot
2. ---
3. This error.


Comment
-----
I have a warning about printer-applet every time I log in
Comment 4 Radek Novacek 2010-07-21 02:34:46 EDT
I reported this bug to the upstream bugzilla [1] and attached there a patch that fixes this issue.

[1] https://bugs.kde.org/show_bug.cgi?id=245289
Comment 5 Dennis Gilmore 2010-07-26 12:17:58 EDT
Package: kdeutils-printer-applet-6:4.4.92-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. log into computer
2. get abort backtrace
3.


Comment
-----
log in to desktop
Comment 6 Karsten Roch 2010-07-27 13:55:48 EDT
Package: kdeutils-printer-applet-6:4.4.92-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. Start KDE

2. Login (Printer is switched off)

3. Crash happens.
Comment 7 Felix Möller 2010-07-28 14:02:24 EDT
Package: kdeutils-printer-applet-6:4.4.95-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
just log into kde
Comment 8 Rex Dieter 2010-07-28 15:45:55 EDT
Sorry, I failed to notice the patch attached upstream.

http://bugs.kde.org/attachment.cgi?id=49356

let's get that integrated asap, and once confirmed fixed, into kde svn.
Comment 9 Tom 2010-07-29 18:47:26 EDT
Package: kdeutils-printer-applet-6:4.4.95-1.fc14.py27
Architecture: i686
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. Occurs at boot into Fedora Rawhide


Comment
-----
Occurs with Rawhide fresh install and also with upgrade from 13
Comment 10 Bug Zapper 2010-07-30 08:38:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Radek Novacek 2010-08-02 06:02:32 EDT
This issue was fixed upstream, see:
https://bugs.kde.org/show_bug.cgi?id=245289
Comment 12 Martin Kho 2010-08-02 16:33:11 EDT
Package: kdeutils-printer-applet-6:4.4.95-1.fc14.py27
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Just login into KDE :-) 
2.
3.
Comment 13 MartinG 2010-08-08 16:22:17 EDT
Package: kdeutils-printer-applet-6:4.4.92-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. Boot system
2. Login to KDE
3. abrt shows crash


Comment
-----
Simply logged in to KDE
Comment 14 Kevin Kofler 2010-08-10 10:38:03 EDT
This is fixed in 4.5.0.
Comment 15 Adam Williamson 2010-08-11 17:03:02 EDT
just a note, this hits F14 Alpha RC3 KDE live, since the fixed package didn't make it into the RC3 spin.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Kevin Kofler 2010-08-11 19:15:05 EDT
Oh joy. :-( Darn, I forgot about that! I don't think we should pull in all of 4.5.0 into the alpha. We could build a package with a backported patch, but of course this would require another alpha RC compose. Grrr…
Comment 17 Kevin Kofler 2010-08-11 19:17:57 EDT
And it seems a desktop that actually works properly is only required for Final according to the release criteria.
Comment 18 Adam Williamson 2010-08-11 22:01:16 EDT
Yes, this issue by itself doesn't constitute an Alpha blocker. We will have an RC4, we might consider taking a fix for this if it's very small and simple. The compose is planned to happen tomorrow (likely afternoon).

(The theory of the Alpha desktop release criteria, btw, is that as long as you can run a browser to read about what's broken and an updater to get the fixes, then that's damn well good enough for an Alpha :). As I did say repeatedly via email, though, the criteria are always open to revision and I'd love to have feedback from the SIGs on what they'd like to see in them.)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Williamson 2010-08-12 14:19:59 EDT
-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Adam Williamson 2010-08-20 17:39:43 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Rex Dieter 2010-09-14 14:29:29 EDT
*** Bug 633951 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.