Bug 633951 - Kdeutils-Printer-Applet Crash
Kdeutils-Printer-Applet Crash
Status: CLOSED DUPLICATE of bug 615651
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-14 14:25 EDT by Giorgi Tavkelishvili
Modified: 2010-09-14 14:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 14:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Giorgi Tavkelishvili 2010-09-14 14:25:56 EDT
architecture: i686
cmdline: python /usr/bin/printer-applet
component: kdeutils
executable: /usr/bin/printer-applet
kernel: 2.6.35-0.57.rc6.git1.fc14.i686.PAE
package: kdeutils-printer-applet-6:4.4.95-1.fc14.py27
reason: posixpath.py:119:dirname:AttributeError: 'QString' object has no attribute 'rfind'
release: Fedora release 14 (Branched)
time: 1284485848
uid: 500

backtrace
-----
posixpath.py:119:dirname:AttributeError: 'QString' object has no attribute 'rfind'

Traceback (most recent call last):
  File "/usr/bin/printer-applet", line 1163, in <module>
    applet = JobManager()
  File "/usr/bin/printer-applet", line 241, in __init__
    uic.loadUi(APPDIR + '/' + "printer-applet.ui", self.mainWindow)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/__init__.py", line 177, in loadUi
    return DynamicUILoader().loadUi(uifile, baseinstance)
  File "/usr/lib/python2.7/site-packages/PyQt4/uic/Loader/loader.py", line 24, in loadUi
    return self.parse(filename, os.path.dirname(filename))
  File "/usr/lib/python2.7/posixpath.py", line 119, in dirname
    i = p.rfind('/') + 1
AttributeError: 'QString' object has no attribute 'rfind'

Local variables in innermost frame:
p: PyQt4.QtCore.QString(u'/usr/share/kde4/apps/printer-applet/printer-applet.ui')

comment
-----
If directly plugged into the machine, the printer is recognized by most - if not all - current Linux distributions (including Fedora). In the current case, printer plugged into the USB port on a router/print server should be treated simply as a network printer.

reproduce
-----
1.Plug an HP Deskjet D2360 or a compatible printer into a USB port on a D-Link DIR-320 router with latest firmware v1.21 to make the printer 'network aware'
2.Insert the Fedora 14 Alpha installation DVD media and boot from it
3.Choose to install KDE SC 4.5 (only) - with default packages for KDE
4.Simply login to your KDE desktop to observe the crash
Comment 1 Rex Dieter 2010-09-14 14:29:29 EDT
Fixed in subsquent updates (latest is kde-4.5.1)

*** This bug has been marked as a duplicate of bug 615651 ***

Note You need to log in before you can comment on or make changes to this bug.