Bug 615946 - libguestfs-find-requires.sh is not autogenerating dependencies for libguestfs
libguestfs-find-requires.sh is not autogenerating dependencies for libguestfs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
14
All Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On: 615870
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 06:47 EDT by Richard W.M. Jones
Modified: 2010-09-08 21:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: libguestfs-1.4.3-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 615870
Environment:
Last Closed: 2010-09-08 21:13:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-07-19 06:47:26 EDT
+++ This bug was initially created as a clone of Bug #615870 +++

Actually the problem is more serious: our custom dependency
generator (libguestfs-find-requires.sh) is no longer working,
not even in Fedora.  This apparently started after we moved to
using febootstrap-supermin-helper.

-----

Problem exists in Rawhide:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=2060621

and in F-13:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=2065514

F-12 and EPEL are OK.
Comment 2 Richard W.M. Jones 2010-07-19 09:00:26 EDT
Build for F-13:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2328850
Comment 3 Fedora Update System 2010-07-19 11:11:53 EDT
libguestfs-1.4.1-1.1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.4.1-1.1.fc13
Comment 4 Bug Zapper 2010-07-30 08:39:34 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Fedora Update System 2010-08-17 18:12:56 EDT
libguestfs-1.4.2-1.1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.4.2-1.1.fc13
Comment 6 Fedora Update System 2010-08-19 22:25:25 EDT
libguestfs-1.4.2-1.1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libguestfs-1.4.2-1.1.fc13
Comment 7 Jinxin Zheng 2010-08-19 23:18:32 EDT
I think I can verify this bug because the shared library dependencies (files under /lib64 and /usr/lib64) are pulled in by the new package,

# rpm -qRp libguestfs-1.4.2-1.1.fc13.x86_64.rpm 
kernel  
bash  
coreutils  
lvm2  
ntfs-3g  
util-linux-ng  
MAKEDEV  
net-tools  
augeas-libs  
file  
module-init-tools  
procps  
strace  
iputils  
dosfstools  
zerofree  
lsof  
scrub  
libselinux  
parted  
e2fsprogs  
btrfs-progs  
gfs2-utils  
hfsplus-tools  
nilfs-utils  
reiserfs-utils  
jfsutils  
xfsprogs  
vim-minimal  
binutils  
grub  
ntfsprogs  
qemu-kvm >= 0.10-7
febootstrap >= 2.7
genisoimage  
/sbin/ldconfig  
/sbin/ldconfig  
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libc.so.6(GLIBC_2.3)(64bit)  
libc.so.6(GLIBC_2.4)(64bit)  
libc.so.6(GLIBC_2.7)(64bit)  
libguestfs.so.0()(64bit)  
/lib64/libkrb5.so.3  
/lib64/libkeyutils.so.1  
/lib64/libnilfs.so.0  
/lib64/libpamc.so.0  
/lib64/libpam.so.0  
/lib64/libe2p.so.2  
/lib64/libnss_dns.so.2  
/lib64/libnss_hesiod.so.2  
/lib64/librt.so.1  
/lib64/libply.so.2  
/lib64/libpcre.so.0  
/lib64/libtinfo.so.5  
/lib64/libkrb5support.so.0  
/lib64/libnss_files.so.2  
/lib64/libnss_nis.so.2  
/lib64/libnss_compat.so.2  
/lib64/libauparse.so.0  
/lib64/libparted-2.1.so.0  
/lib64/libnsl.so.1  
/lib64/libgio-2.0.so.0  
/lib64/libc.so.6  
/lib64/libip4tc.so.0  
/lib64/libgcrypt.so.11  
/lib64/libipq.so.0  
/lib64/libhandle.so.1  
/lib64/libcidn.so.1  
/lib64/ld-linux-x86-64.so.2  
/lib64/libuuid.so.1  
/lib64/libnih.so.1  
/lib64/libncurses.so.5  
/lib64/libgssrpc.so.4  
/lib64/libglib-2.0.so.0  
/lib64/libblkid.so.1  
/lib64/libidn.so.11  
/lib64/libiptc.so.0  
/lib64/libk5crypto.so.3  
/lib64/libdmraid.so.1  
/lib64/libudev.so.0  
/lib64/libip6tc.so.0  
/lib64/libext2fs.so.2  
/lib64/libpam_misc.so.0  
/lib64/.libgcrypt.so.11.hmac  
/lib64/libcom_err.so.2  
/lib64/libm.so.6  
/lib64/libcryptsetup.so.1  
/lib64/libz.so.1  
/lib64/libcrypt.so.1  
/lib64/libselinux.so.1  
/lib64/libxtables.so.4  
/lib64/libbz2.so.1  
/lib64/libcap-ng.so.0  
/lib64/libgssapi_krb5.so.2  
/lib64/libdbus-1.so.3  
/lib64/libpopt.so.0  
/lib64/libgmodule-2.0.so.0  
/lib64/libcap.so.2  
/lib64/rtkaio/librt.so.1  
/lib64/libresolv.so.2  
/lib64/libreadline.so.6  
/lib64/libpthread.so.0  
/lib64/libncursesw.so.5  
/lib64/libattr.so.1  
/lib64/.libcrypto.so.1.0.0a.hmac  
/lib64/libanl.so.1  
/lib64/libdl.so.2  
/lib64/libgobject-2.0.so.0  
/lib64/libcrypto.so.10  
/lib64/libgthread-2.0.so.0  
/lib64/libBrokenLocale.so.1  
/lib64/libacl.so.1  
/lib64/libthread_db.so.1  
/lib64/.libcrypto.so.10.hmac  
/lib64/libnih-dbus.so.1  
/lib64/libaudit.so.1  
/lib64/libnss_nisplus.so.2  
/lib64/libgcc_s.so.1  
/lib64/libgpg-error.so.0  
/lib64/libdmraid-events-isw.so.1  
/lib64/libutil.so.1  
/lib64/libss.so.2  
/lib64/libsepol.so.1  
/usr/lib64/libaugeas.so.0  
/usr/lib64/libformw.so.5  
/usr/lib64/libmenuw.so.5  
/usr/lib64/libmenu.so.5  
/usr/lib64/libkdb5.so.4  
/usr/lib64/libconfig.so.8  
/usr/lib64/libdrm_intel.so.1  
/usr/lib64/libcrack.so.2  
/usr/lib64/libgnutlsxx.so.26  
/usr/lib64/libfa.so.1  
/usr/lib64/.libssl.so.1.0.0a.hmac  
/usr/lib64/libtic.so.5  
/usr/lib64/libgnutls.so.26  
/usr/lib64/libgmp.so.3  
/usr/lib64/libgmpxx.so.4  
/usr/lib64/libkadm5clnt.so.6  
/usr/lib64/libpanel.so.5  
/usr/lib64/libgnutls-extra.so.26  
/usr/lib64/libssl.so.10  
/usr/lib64/libhistory.so.6  
/usr/lib64/libmp.so.3  
/usr/lib64/libmagic.so.1  
/usr/lib64/libconfig++.so.8  
/usr/lib64/libdrm_radeon.so.1  
/usr/lib64/libelf.so.1  
/usr/lib64/libform.so.5  
/usr/lib64/libdrm.so.2  
/usr/lib64/libpcreposix.so.0  
/usr/lib64/libgamin-1.so.0  
/usr/lib64/libkadm5srv.so.6  
/usr/lib64/libatm.so.1  
/usr/lib64/libkms.so.1  
/usr/lib64/libdrm_nouveau.so.1  
/usr/lib64/libpcrecpp.so.0  
/usr/lib64/libusbpp-0.1.so.4  
/usr/lib64/libusb-0.1.so.4  
/usr/lib64/libntfs.so.10  
/usr/lib64/libpanelw.so.5  
/usr/lib64/liblzma.so.0  
/usr/lib64/libtasn1.so.3  
/usr/lib64/libstdc++.so.6  
/usr/lib64/libfam.so.0  
/usr/lib64/libgnutls-openssl.so.26  
/usr/lib64/.libssl.so.10.hmac  
rpmlib(PayloadIsXz) <= 5.2-1

It is similar with the i686 version.

Please point out if you found this verification improper.
Comment 8 Richard W.M. Jones 2010-08-20 03:44:09 EDT
Yes, they are now being generated correctly.
Comment 9 Fedora Update System 2010-08-27 15:27:45 EDT
libguestfs-1.4.3-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/libguestfs-1.4.3-3.fc13
Comment 10 Fedora Update System 2010-08-30 14:26:53 EDT
libguestfs-1.4.3-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/libguestfs-1.4.3-3.fc13
Comment 11 Jinxin Zheng 2010-08-30 22:19:23 EDT
The same verification was done as in comment 7. No additional problem.
Comment 12 Fedora Update System 2010-09-08 21:13:08 EDT
libguestfs-1.4.3-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.