This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 616399 - python-pip pkg conflict with perl-pip
python-pip pkg conflict with perl-pip
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-pip (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Flink
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 616626
  Show dependency treegraph
 
Reported: 2010-07-20 07:05 EDT by Adam Stokes
Modified: 2011-06-24 11:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 616626 (view as bug list)
Environment:
Last Closed: 2011-06-24 11:17:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Stokes 2010-07-20 07:05:25 EDT
Description of problem:
Attempting to do a wildcard install of both python and perl packages results a file conflict for both python-pip and perl-pip

Version-Release number of selected component (if applicable):
python-pip 0.6.3-1 & perl-perl 1.16-1

How reproducible:
100%

Steps to Reproduce:
1. yum install python* perl*
2.
3.
  
Actual results:
Running Transaction Test


Transaction Check Error:
  file /usr/bin/pip conflicts between attempted installs of python-pip-0.6.3-1.fc13.noarch and perl-pip-1.16-1.fc13.noarch


Expected results:
No conflicts

Additional info:
Comment 1 Peter Halliday 2010-07-20 13:32:36 EDT
Not sure how this is going to be resolved.  Both packages require the same filename.  I'm consulting with the upstream people. However, you almost never should do a yum install python* or yum install perl*, because you usually shouldn't install everything.  But the last comment is more editorial.
Comment 2 Adam Stokes 2010-07-20 14:19:17 EDT
(In reply to comment #1)
> Not sure how this is going to be resolved.  Both packages require the same
> filename.  I'm consulting with the upstream people. 

Thanks
> However, you almost never
> should do a yum install python* or yum install perl*, because you usually
> shouldn't install everything.  But the last comment is more editorial.    

Agreed, however, for completeness sake we should not be running into packages that could potentially overwrite other packages executables.

Thanks for looking into this!
Comment 3 Peter Halliday 2010-07-20 14:26:35 EDT
Well, I think the Debian approach (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=551926) should be done here.  Both packages should have to rename their /usr/bin/pip.  Something like /usr/bin/pip-perl and /usr/bin/pip-python.  That way completion will work at least.
Comment 4 Adam Stokes 2010-07-20 14:49:15 EDT
I like it, should I file a duplicate bug for perl-pip or will you handle that transaction?

Thanks for the quick replies
Comment 5 Peter Halliday 2010-07-20 15:27:41 EDT
I would appreciate it if you file this bug.  For political reasons, I don't want it to look like I'm targeting perl-pip in any way.
Comment 6 Adam Stokes 2010-07-20 21:42:43 EDT
Sure thing thanks again
Comment 7 Bug Zapper 2010-07-30 08:42:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Marcela Mašláňová 2010-08-31 08:44:16 EDT
Ping? Perl bug was fixed.
Comment 9 Peter Halliday 2010-08-31 09:12:35 EDT
I'm submitting my fix now.  having some trouble getting to know the new build process now that we're on git.  So should have mine in soon.
Comment 10 Fedora Admin XMLRPC Client 2011-06-22 14:09:05 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Fedora Admin XMLRPC Client 2011-06-22 14:10:12 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Tim Flink 2011-06-24 11:17:35 EDT
This was completed a while ago but the bug was never closed. Closing now.

Note You need to log in before you can comment on or make changes to this bug.