Bug 616626 - python-pip pkg conflict with perl-pip
Summary: python-pip pkg conflict with perl-pip
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-pip   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 616399
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-21 01:44 UTC by Adam Stokes
Modified: 2010-08-04 08:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 616399
Environment:
Last Closed: 2010-08-04 08:21:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 59589 None None None Never

Description Adam Stokes 2010-07-21 01:44:54 UTC
+++ This bug was initially created as a clone of Bug #616399 +++

Description of problem:
Attempting to do a wildcard install of both python and perl packages results a file conflict for both python-pip and perl-pip

Version-Release number of selected component (if applicable):
python-pip 0.6.3-1 & perl-pip 1.16-1

How reproducible:
100%

Steps to Reproduce:
1. yum install python* perl*
2.
3.
  
Actual results:
Running Transaction Test


Transaction Check Error:
  file /usr/bin/pip conflicts between attempted installs of python-pip-0.6.3-1.fc13.noarch and perl-pip-1.16-1.fc13.noarch


Expected results:
No conflicts

Additional info:


--- Additional comment from phalliday@excelsiorsystems.net on 2010-07-20 14:26:35 EDT ---

Well, I think the Debian approach (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=551926) should be done here.  Both packages should have to rename their /usr/bin/pip.  Something like /usr/bin/pip-perl and /usr/bin/pip-python.  That way completion will work at least.

Comment 1 Marcela Mašláňová 2010-07-21 07:11:09 UTC
Thanks for your bug report. I've created bug report in upstream as stated in our guidelines [1]. Let's wait for a while for their opinion.

[1] https://fedoraproject.org/wiki/Packaging:Conflicts#Binary_Name_Conflicts

Comment 2 Bug Zapper 2010-07-30 12:43:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Marcela Mašláňová 2010-08-03 12:20:46 UTC
No reply from upstream yet and also python pip wasn't still fixed.

Comment 4 Peter Halliday 2010-08-03 13:32:38 UTC
I haven't fixed this yet, because I'm waiting to hear what was going to happen with the perl-pip.  I doubt they will change, because both parties upstream had this "battle" debian.  And the packages had to rename them to pip-perl and pip-python, because neither would change their name.  I certainly am willing to make the changes, but I want to make sure both were planned to be changed.

Comment 5 Marcela Mašláňová 2010-08-04 08:21:27 UTC
Ok, I read the whole fight about who was here first with pip... It's ridiculous. 

Let's both change it to python-pip and perl-pip for rawhide. In my case only perl-Padre is using pip and it looks to be working even after rename.

Build with fix:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2378618


Note You need to log in before you can comment on or make changes to this bug.