Bug 616405 - Job containing canceled recipes still reports "Completed" as the overall status
Summary: Job containing canceled recipes still reports "Completed" as the overall status
Status: CLOSED DUPLICATE of bug 714937
Alias: None
Product: Beaker
Classification: Community
Component: scheduler   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard: Misc
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-20 11:29 UTC by Petr Šplíchal
Modified: 2016-08-08 05:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-08 05:00:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petr Šplíchal 2010-07-20 11:29:47 UTC
Description of problem:

I've canceled two recipes (out of four) in TJ#8073. The other two
recipes were completed at that time. The overall status now says:
"Completed". I believe "Canceled" would be more appropriate for
this situation.

Version-Release number of selected component (if applicable):
0.5.49

https://beaker.engineering.redhat.com/jobs/8073

Comment 2 Nick Coghlan 2012-10-17 04:36:47 UTC
Bulk reassignment of issues as Bill has moved to another team.

Comment 5 Dan Callaghan 2016-08-08 05:00:07 UTC
This was fixed in Beaker 21.0 for bug 714937. A job with some recipes Completed and some Cancelled will now have an overall status of Cancelled.

*** This bug has been marked as a duplicate of bug 714937 ***


Note You need to log in before you can comment on or make changes to this bug.