Bug 616421 - [abrt] crash in qbittorrent-2.2.9-1.fc13: Process /usr/bin/qbittorrent was killed by signal 11 (SIGSEGV)
[abrt] crash in qbittorrent-2.2.9-1.fc13: Process /usr/bin/qbittorrent was ki...
Status: CLOSED DUPLICATE of bug 581760
Product: Fedora
Classification: Fedora
Component: qbittorrent (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:3e7fd5bf1cf574ba1d226ce34e0...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 08:29 EDT by John de Loos
Modified: 2010-07-21 22:49 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 22:49:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.72 KB, text/plain)
2010-07-20 08:29 EDT, John de Loos
no flags Details

  None (edit)
Description John de Loos 2010-07-20 08:29:48 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: qbittorrent
component: qbittorrent
executable: /usr/bin/qbittorrent
global_uuid: 3e7fd5bf1cf574ba1d226ce34e0ffe16eda74023
kernel: 2.6.33.6-147.fc13.i686
package: qbittorrent-2.2.9-1.fc13
rating: 3
reason: Process /usr/bin/qbittorrent was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 John de Loos 2010-07-20 08:29:50 EDT
Created attachment 433146 [details]
File: backtrace
Comment 2 Kevin Kofler 2010-07-20 09:02:42 EDT
Looks like this is a different backtrace than the usual QMultiInputContext ones. But I suspect that this is actually a problem with the QtSingleApplication code which qbittorrent bundles (in violation of the "no bundled libraries" guideline).
Comment 3 Kevin Kofler 2010-07-20 09:32:15 EDT
I guess it's the same bug.

*** This bug has been marked as a duplicate of bug 581760 ***
Comment 4 leigh scott 2010-07-20 10:32:00 EDT
(In reply to comment #2)
> Looks like this is a different backtrace than the usual QMultiInputContext
> ones. But I suspect that this is actually a problem with the
> QtSingleApplication code which qbittorrent bundles (in violation of the "no
> bundled libraries" guideline).    

I have reverted to 2.2.8 and will discuss the issue with upstream.

http://koji.fedoraproject.org/koji/buildinfo?buildID=184709
Comment 5 Kevin Kofler 2010-07-20 11:24:22 EDT
FWIW, QtSingleApplication is also used by Clementine, some people were interested in packaging it, you may want to talk to them about packaging QtSingleApplication and its dependency QtLockedFile properly.

(And :-( , this functionality has been provided by kdelibs for ages, why do people have to reinvent all of kdelibs just to be Qt-only? Qt-only apps suck!)
Comment 6 Kevin Kofler 2010-07-20 11:26:05 EDT
(And also FWIW, the crash can't be caused by QtSingleApplication because older versions without it already had this crash. It must be some issue elsewhere in qbittorrent.)
Comment 7 leigh scott 2010-07-20 11:43:01 EDT
(In reply to comment #5)
> FWIW, QtSingleApplication is also used by Clementine, some people were
> interested in packaging it, you may want to talk to them about packaging
> QtSingleApplication and its dependency QtLockedFile properly.
> 


Thanks for pointing out the bundled lib, I didn't notice it's introduction in version 2.2.9 as I was busy with moving home.
I have pushed the epoched 2.2.8 version straight to stable.
Have you got the review link for Clementine?
I have also reported the issue upstream to see if Chris can include a ./configure option so it can use the external lib.
Comment 8 Rex Dieter 2010-07-20 11:52:48 EDT
clementine review is bug #583327
Comment 9 leigh scott 2010-07-20 12:05:17 EDT
(In reply to comment #8)
> clementine review is bug #583327    

Thanks Rex.

It looks like both required libs have already approved :cool:

https://bugzilla.redhat.com/show_bug.cgi?id=582864

https://bugzilla.redhat.com/show_bug.cgi?id=581220
Comment 10 Kevin Kofler 2010-07-20 13:22:11 EDT
Looks like this one may actually be a different issue, since this is not input context related whereas the proposed patch for the other bug is.
Comment 11 Kevin Kofler 2010-07-21 22:49:11 EDT
Probably a duplicate after all, looks like I was right about the crashes on exit being a qbittorrent bug. :-)

*** This bug has been marked as a duplicate of bug 581760 ***

Note You need to log in before you can comment on or make changes to this bug.