Bug 581760 - [abrt] crash in qbittorrent-2.2.5-1.fc12: Process /usr/bin/qbittorrent was killed by signal 11 (SIGSEGV)
[abrt] crash in qbittorrent-2.2.5-1.fc12: Process /usr/bin/qbittorrent was ki...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qbittorrent (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:e6de1f618eeb4532476c312a9ff...
: MoveUpstream
: 583196 583264 591328 592552 592656 595149 598669 600833 603479 604506 610994 610995 610997 614223 615784 616421 616542 617681 617791 617902 618051 618127 618604 619352 619852 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-13 03:45 EDT by Adrian bartlett
Modified: 2010-12-03 13:14 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 13:14:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.27 KB, text/plain)
2010-04-13 03:45 EDT, Adrian bartlett
no flags Details

  None (edit)
Description Adrian bartlett 2010-04-13 03:45:08 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: qbittorrent
component: qbittorrent
executable: /usr/bin/qbittorrent
kernel: 2.6.31.5-127.fc12.x86_64
package: qbittorrent-2.2.5-1.fc12
rating: 3
reason: Process /usr/bin/qbittorrent was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.not sure
2.
3.
Comment 1 Adrian bartlett 2010-04-13 03:45:11 EDT
Created attachment 406169 [details]
File: backtrace
Comment 2 leigh scott 2010-04-13 05:36:55 EDT
Reassigned to qt
Comment 3 leigh scott 2010-04-17 04:14:03 EDT
*** Bug 583196 has been marked as a duplicate of this bug. ***
Comment 4 Steven M. Parrish 2010-05-05 07:55:07 EDT
This is an issue which needs to be addressed by the upstream developers.  Please file a report at http://bugs.kde.org  once that is done please add the upstream bug information to this report.  We will monitor the upstream report for a resolution. 

Thanks
Comment 5 Kevin Kofler 2010-05-15 21:02:01 EDT
*** Bug 592656 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Kofler 2010-05-16 10:49:58 EDT
*** Bug 592552 has been marked as a duplicate of this bug. ***
Comment 7 Kevin Kofler 2010-05-16 10:50:27 EDT
*** Bug 583264 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Kofler 2010-05-16 10:51:10 EDT
*** Bug 591328 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Kofler 2010-05-23 21:31:07 EDT
*** Bug 595149 has been marked as a duplicate of this bug. ***
Comment 10 leigh scott 2010-05-24 06:38:29 EDT
(In reply to comment #4)
> This is an issue which needs to be addressed by the upstream developers. 
> Please file a report at http://bugs.kde.org  once that is done please add the
> upstream bug information to this report.  We will monitor the upstream report
> for a resolution. 
> 
> Thanks    

Why http://bugs.kde.org ?
Comment 11 Rex Dieter 2010-05-24 10:37:11 EDT
I think bko was just a paste-o , qt upstream is nokia, whose tracker is at

http://bugreports.qt.nokia.com/
Comment 12 Kevin Kofler 2010-06-02 03:29:01 EDT
*** Bug 598669 has been marked as a duplicate of this bug. ***
Comment 13 leigh scott 2010-06-02 04:45:03 EDT
(In reply to comment #9)
> *** Bug 595149 has been marked as a duplicate of this bug. ***    

Bug 595149 was filed against the F13 qt package
Comment 14 Kevin Kofler 2010-06-06 07:15:56 EDT
*** Bug 600833 has been marked as a duplicate of this bug. ***
Comment 15 leigh scott 2010-06-13 08:51:58 EDT
*** Bug 603479 has been marked as a duplicate of this bug. ***
Comment 16 Kevin Kofler 2010-06-16 09:34:40 EDT
*** Bug 604506 has been marked as a duplicate of this bug. ***
Comment 17 Kevin Kofler 2010-07-18 18:28:45 EDT
*** Bug 614223 has been marked as a duplicate of this bug. ***
Comment 18 Kevin Kofler 2010-07-18 18:28:50 EDT
*** Bug 610995 has been marked as a duplicate of this bug. ***
Comment 19 Kevin Kofler 2010-07-18 18:28:54 EDT
*** Bug 610997 has been marked as a duplicate of this bug. ***
Comment 20 Kevin Kofler 2010-07-18 18:28:59 EDT
*** Bug 610994 has been marked as a duplicate of this bug. ***
Comment 21 Kevin Kofler 2010-07-20 09:32:15 EDT
*** Bug 616421 has been marked as a duplicate of this bug. ***
Comment 22 Kevin Kofler 2010-07-20 09:37:44 EDT
So all these bugs have in common that qbittorrent crashes while destroying the QApplication, usually in QMultiInputContext. It is the only app we're getting these reports for, and qbittorrent's source code has this to say:

qDebug("Deleting app...");
#ifndef Q_WS_WIN
    // XXX: Why does it crash on Windows in QWindowsVistaStyle destructor!?
    delete app;
#endif

so it looks like they're already noticing crashes during QApplication destruction on other platforms. I suspect some memory corruption inside qbittorrent. Please try running qbittorrent in Valgrind to see if that tells us the true cause of the bug. At this stage, I really don't think it's a Qt bug, sorry.

The crashes should also be reported to qbittorrent upstream on SourceForge.
Comment 23 Christophe Dumez 2010-07-20 11:51:57 EDT
Can this be reproduced with a recent qBittorrent version (v2.2.10)?

There used to be an issue where the QApplication was instantiated too late in the main() and this was fixed in v2.2.9 or v2.2.10.

Regarding the piece of code provided by Kevin Kofler. This is outdated and no longer existing in recent qBittorrent. This was added temporarily until we finished Windows porting. Just so you know, the crash when deleting the QApplication was due to linking problems on Windows and not to a bug in qBittorrent.
Comment 24 leigh scott 2010-07-20 12:11:45 EDT
(In reply to comment #23)
> Can this be reproduced with a recent qBittorrent version (v2.2.10)?
> 
> There used to be an issue where the QApplication was instantiated too late in
> the main() and this was fixed in v2.2.9 or v2.2.10.
> 
  

Yes it was still present in 2.2.9

https://bugzilla.redhat.com/show_bug.cgi?id=610995
Comment 25 Christophe Dumez 2010-07-20 12:16:16 EDT
Any Fedora-specific patches/changes?

I'm asking because I'm not getting similar reports from other distributions users but there seems to be a lot of duplicates reports here...

Anyway, I will follow Kevin Kofler's hint and use Valgrind to debug possible memory problems. I hope we can figure out the reason soon.
Comment 26 Kevin Kofler 2010-07-20 12:25:12 EDT
Well, Fedora is using an automated crash intercepting and reporting tool which has been used to file all those reports: https://fedoraproject.org/wiki/Features/ABRT

It's quite likely that crashes on exit in a GUI app (i.e. an app normally run from a menu, not a terminal) otherwise go entirely unnoticed.
Comment 27 Christophe Dumez 2010-07-20 13:07:04 EDT
This is a known bug in Qt 4.6:
http://bugreports.qt.nokia.com/browse/QTBUG-7105

Here is the patch I propose:
http://launchpadlibrarian.net/52219219/force-inputcontext.patch

I have implemented in the patch the workaround proposed in the Qt bug report:
***
Another workaround would be to make sure the input context is created BEFORE the application destructor is called, e.g. for KDE, this could be done inside KApplication by just calling (void) QApplication::inputContext() for GUI applications.
***

In my case, I create the input context just after creating the QApplication.
Comment 28 Christophe Dumez 2010-07-20 13:08:04 EDT
By the way, my patch is a workaround for qBittorrent, not a patch for Qt.
Comment 29 Kevin Kofler 2010-07-20 13:14:26 EDT
We could also apply a Qt patch if there's a known one, but I guess that for now the qbittorrent workaround is the easiest fix.

What I wonder is why qbittorrent is the only app we get bug reports about.
Comment 30 Christophe Dumez 2010-07-20 13:27:27 EDT
Here is the known Qt patch:
http://qt.gitorious.org/qt/staging/commit/f72165460d27860cabd51691f4d935fd74b50f80
Comment 31 Christophe Dumez 2010-07-20 13:34:44 EDT
By the way, I have Qt 4.6.2 and it already contains the fix.

Only Qt 4.6.0 (and maybe Qt 4.6.1?) seem to be affected
Comment 32 Kevin Kofler 2010-07-20 13:52:33 EDT
Then either it's not that bug or the fix does not work. We have 4.6.3 (pushed on July 13), and before that we had 4.6.2 (pushed to F12 on February 24 along with KDE 4.4.0, F13 shipped with it).
Comment 33 Christophe Dumez 2010-07-21 10:09:25 EDT
I believe this is fixed in v2.2.11 (both the crash on exit and the library shipping).

It seems it was caused by an error on my code after all, mea culpa.
My memory clean up code was a little too extreme and it was sometimes destructing objects belonging to the QApplication instance.

I hope that all is in order now. Sorry not fixing this earlier but it was tricky to debug.
Comment 34 Kevin Kofler 2010-07-21 22:49:11 EDT
*** Bug 616421 has been marked as a duplicate of this bug. ***
Comment 35 leigh scott 2010-07-29 08:19:37 EDT
*** Bug 619352 has been marked as a duplicate of this bug. ***
Comment 36 leigh scott 2010-07-29 08:21:01 EDT
*** Bug 618604 has been marked as a duplicate of this bug. ***
Comment 37 leigh scott 2010-07-29 08:21:38 EDT
*** Bug 618127 has been marked as a duplicate of this bug. ***
Comment 38 leigh scott 2010-07-29 08:22:07 EDT
*** Bug 618051 has been marked as a duplicate of this bug. ***
Comment 39 leigh scott 2010-07-29 08:23:59 EDT
*** Bug 617902 has been marked as a duplicate of this bug. ***
Comment 40 leigh scott 2010-07-29 08:25:47 EDT
*** Bug 617791 has been marked as a duplicate of this bug. ***
Comment 41 leigh scott 2010-07-29 08:27:57 EDT
*** Bug 616542 has been marked as a duplicate of this bug. ***
Comment 42 leigh scott 2010-07-29 08:28:42 EDT
*** Bug 615784 has been marked as a duplicate of this bug. ***
Comment 43 leigh scott 2010-07-29 08:29:29 EDT
*** Bug 617681 has been marked as a duplicate of this bug. ***
Comment 44 leigh scott 2010-07-30 14:16:20 EDT
*** Bug 619852 has been marked as a duplicate of this bug. ***
Comment 45 John de Loos 2010-08-06 11:22:48 EDT
Package: qbittorrent-1:2.2.8-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Starting Qbittorrent
2. Closing Qbittorrent
3.
Comment 46 Christophe Dumez 2010-08-07 06:30:43 EDT
Leigh > I see that John de Loos still has v2.2.8. I am confident that this bug was fixed in v2.2.11. Did you cherry pick the patch for your v2.2.8 package or not?
Comment 47 John de Loos 2010-08-08 04:48:22 EDT
Package: qbittorrent-1:2.2.8-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Closing qBittorrent
2.
3.
Comment 48 leigh scott 2010-12-03 13:14:46 EST
(In reply to comment #46)
> Leigh > I see that John de Loos still has v2.2.8. I am confident that this bug
> was fixed in v2.2.11. Did you cherry pick the patch for your v2.2.8 package or
> not?

The reports have stopped so I will close this Br.

Note You need to log in before you can comment on or make changes to this bug.