Bug 616507 - cpuspeed does not reset MIN/MAX values when config file is emptied
cpuspeed does not reset MIN/MAX values when config file is emptied
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 616524
  Show dependency treegraph
 
Reported: 2010-07-20 12:32 EDT by François Cami
Modified: 2010-07-26 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: cpuspeed-1.5-14.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 616524 616976 (view as bug list)
Environment:
Last Closed: 2010-07-26 22:21:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for /etc/init.d/cpuspeed (566 bytes, patch)
2010-07-20 12:32 EDT, François Cami
no flags Details | Diff

  None (edit)
Description François Cami 2010-07-20 12:32:50 EDT
Created attachment 433207 [details]
patch for /etc/init.d/cpuspeed

Description of problem:
When MIN_SPEED (resp. MAX_SPEED) is set in /etc/sysconfig/cpuspeed, and then removed, /etc/init.d/cpuspeed does not reset the value to the CPU minimum (resp. maximum) frequency.

Version-Release number of selected component (if applicable):
cpuspeed-1.5-13.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
0. check CPU frequency using cat /proc/cpuinfo
1. Set MIN_SPEED in /etc/sysconfig/cpuspeed to a suitable value superior to the CPU's minimum frequency
2. restart cpuspeed
3. Unset MIN_SPEED (restore configuration file)
4. restart cpuspeed
5. check CPU frequency using cat /proc/cpuinfo
  
Actual results:
CPU frequency in step 5 is equal to the MIN_SPEED set at step 1.

Expected results:
CPU frequency in steps 0 and 5 are identical.

Additional info:
This is because the cpuspeed script does not reset the values when the {MIN_SPEED,MAX_SPEED} variables are empty. A (crude) patch to do that is attached.
Comment 1 Fedora Update System 2010-07-21 08:11:29 EDT
cpuspeed-1.5-14.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/cpuspeed-1.5-14.fc13
Comment 2 Petr Šabata 2010-07-21 08:18:13 EDT
Thank you for the patch.
This should now be fixed in 1:1.5-14 in both Fedora 13 and Rawhide.
Comment 3 François Cami 2010-07-21 15:57:49 EDT
Petr,

You are welcome.

The koji build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=184831
fixes the bug on my Athlon X2.

I suppose bodhi will close this bug once the package is pushed to updates.
Comment 4 Petr Šabata 2010-07-22 04:35:15 EDT
(In reply to comment #3)
> Petr,
> 
> You are welcome.
> 
> The koji build:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=184831
> fixes the bug on my Athlon X2.
> 
> I suppose bodhi will close this bug once the package is pushed to updates.    

Yes, it does so once the maximum positive karma (three in this case) is reached or certain amount of time passes.
Comment 5 Fedora Update System 2010-07-22 22:24:25 EDT
cpuspeed-1.5-14.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cpuspeed'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/cpuspeed-1.5-14.fc13
Comment 6 Fedora Update System 2010-07-26 22:21:16 EDT
cpuspeed-1.5-14.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.