Bug 616524 - cpuspeed does not reset MIN/MAX values when config file is emptied
Summary: cpuspeed does not reset MIN/MAX values when config file is emptied
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cpuspeed   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: Evan McNabb
URL:
Whiteboard:
Keywords:
Depends On: 616507
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-20 17:22 UTC by François Cami
Modified: 2013-04-15 09:09 UTC (History)
4 users (show)

Fixed In Version: cpuspeed-1.2.1-10.el5
Doc Type: Bug Fix
Doc Text:
The /etc/sysconfig/cpuspeed configuration file allows a user to specify custom maximum (the "MAX_SPEED" option) and minimum (the "MIN_SPEED" option) clock speed limits. Prior to this update, when a user removed these custom settings from the configuration and restarted the service, the cpuspeed init script failed to reset these values to the hardware-specific limits. With this update, the init script has been adapted to ensure that when the minimum or maximum clock speed value is not specified, cpuspeed correctly uses the value reported by the CPU.
Story Points: ---
Clone Of: 616507
Environment:
Last Closed: 2011-05-11 07:25:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for /etc/init.d/cpuspeed (566 bytes, patch)
2010-07-20 17:29 UTC, François Cami
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0502 normal SHIPPED_LIVE cpuspeed bug fix update 2011-05-11 07:25:04 UTC

Description François Cami 2010-07-20 17:22:53 UTC
+++ This bug was initially created as a clone of Bug #616507 +++

Description of problem:
When MIN_SPEED (resp. MAX_SPEED) is set in /etc/sysconfig/cpuspeed, and then removed, /etc/init.d/cpuspeed does not reset the value to the CPU minimum (resp. maximum) frequency.

Version-Release number of selected component (if applicable):
cpuspeed-1.2.1-9.el5

How reproducible:
Always

Steps to Reproduce:
0. check CPU frequency using cat /proc/cpuinfo
1. Set MIN_SPEED in /etc/sysconfig/cpuspeed to a suitable value superior to the CPU's minimum frequency
2. restart cpuspeed
3. Unset MIN_SPEED (restore configuration file)
4. restart cpuspeed
5. check CPU frequency using cat /proc/cpuinfo
  
Actual results:
CPU frequency in step 5 is equal to the MIN_SPEED set at step 1.

Expected results:
CPU frequency in steps 0 and 5 are identical.

Additional info:
This is because the cpuspeed script does not reset the values when the {MIN_SPEED,MAX_SPEED} variables are empty. The original patch attached is for Fedora 13, a RHEL5 patch is coming shortly.

Comment 1 François Cami 2010-07-20 17:29:54 UTC
Created attachment 433223 [details]
patch for /etc/init.d/cpuspeed

patch for F13, applies cleanly on RHEL5.

Comment 3 RHEL Product and Program Management 2010-08-09 18:16:35 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 5 Petr Šabata 2011-03-07 14:33:23 UTC
Initscript fixed in CVS tag cpuspeed-1.2.1-10.el5.

Comment 7 Jaromir Hradilek 2011-04-12 15:12:26 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The /etc/sysconfig/cpuspeed configuration file allows a user to specify custom maximum (the "MAX_SPEED" option) and minimum (the "MIN_SPEED" option) clock speed limits. Prior to this update, when a user removed these custom settings from the configuration and restarted the service, the cpuspeed init script failed to reset these values to the hardware-specific limits. With this update, the init script has been adapted to ensure that when the minimum or maximum clock speed value is not specified, cpuspeed correctly uses the value reported by the CPU.

Comment 9 errata-xmlrpc 2011-05-11 07:25:10 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0502.html


Note You need to log in before you can comment on or make changes to this bug.