Bug 616588 - [abrt] crash in calibre-0.6.55-1.fc13: writer.py:202:_write:TypeError: __init__() got an unexpected keyword argument 'title'
[abrt] crash in calibre-0.6.55-1.fc13: writer.py:202:_write:TypeError: __init...
Status: CLOSED DUPLICATE of bug 653902
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:7883edb3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 17:00 EDT by cerro6
Modified: 2011-01-09 14:51 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-09 14:51:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (653 bytes, text/plain)
2010-07-20 17:00 EDT, cerro6
no flags Details

  None (edit)
Description cerro6 2010-07-20 17:00:08 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: python /usr/bin/calibre-parallel
component: calibre
executable: /usr/bin/calibre-parallel
kernel: 2.6.33.6-147.fc13.i686
package: calibre-0.6.55-1.fc13
reason: writer.py:202:_write:TypeError: __init__() got an unexpected keyword argument 'title'
release: Fedora release 13 (Goddard)

backtrace
-----
writer.py:202:_write:TypeError: __init__() got an unexpected keyword argument 'title'

Traceback (most recent call last):
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 173, in _render_html
    self._render_book()
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 145, in _render_book
    self._write()
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 202, in _write
    outPDF = PdfFileWriter(title=self.metadata.title, author=self.metadata.author)
TypeError: __init__() got an unexpected keyword argument 'title'

Local variables in innermost frame:
self: <calibre.ebooks.pdf.writer.PDFWriter object at 0xc9c62ec>
Comment 1 cerro6 2010-07-20 17:00:13 EDT
Created attachment 433263 [details]
File: backtrace
Comment 2 Kevin Fenzi 2010-07-22 01:25:20 EDT
What were you doing when this happened? Converting a pdf?

Is the source file available on the net or can you attach it?

Also, can you try the newest version available at: 
http://www.scrye.com/~kevin/fedora/calibre/13/i686/ 
and see if you can duplicate the crash with that version?
Comment 3 cerro6 2010-07-24 12:38:33 EDT
I solved the problem by downloading the file in .LIT
thanks
Comment 4 Kevin Fenzi 2010-07-24 16:29:57 EDT
ok, glad you worked around the bug. 

Should we leave this open and see if it is fixed in a newer version? Or would you prefer we just close it for now?
Comment 5 Nicolas Sapa 2010-07-25 04:59:01 EDT
Package: calibre-0.6.55-1.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Try to convert a EPUB to a PDF
2.
3.
Comment 6 Nicolas Sapa 2010-07-25 05:00:12 EDT
The source file is available here => http://www.epubbud.com/book.php?g=4JE3UQ2A
Comment 7 Frank Murphy 2010-07-25 05:10:00 EDT
Can you test with:
http://www.scrye.com/~kevin/fedora/calibre/12/x86_64/

You will also need an updated python-cssutils to version 2.7 
(still in pre-release)
Comment 8 Michael Vergallen 2010-09-04 05:31:04 EDT
Package: calibre-0.6.55-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. convert ebub to pdf 
2.
3.


Comment
-----
convert a epub to pdf
Comment 9 Lev Shamardin 2010-09-29 13:25:38 EDT
Package: calibre-0.6.55-1.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Run something like ebook-convert filename.fb2 filename.pdf
Comment 10 trevor boundy 2010-12-16 04:50:10 EST
Package: calibre-0.6.55-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.from a loaded *.mobi file
2.select conver to rtf
3.cused the fiollowing crash
Comment 11 Kevin Fenzi 2011-01-09 14:51:08 EST

*** This bug has been marked as a duplicate of bug 653902 ***

Note You need to log in before you can comment on or make changes to this bug.