Bug 653902 - [abrt] calibre-0.7.23-1.fc14: writer.py:206:_write:TypeError: __init__() got an unexpected keyword argument 'title'
Summary: [abrt] calibre-0.7.23-1.fc14: writer.py:206:_write:TypeError: __init__() got ...
Status: CLOSED DUPLICATE of bug 673604
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d7ac30cf
Keywords:
: 601445 616588 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-16 12:45 UTC by antonio montagnani
Modified: 2011-03-20 23:49 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-03-20 23:49:13 UTC


Attachments (Terms of Use)
File: backtrace (653 bytes, text/plain)
2010-11-16 12:45 UTC, antonio montagnani
no flags Details

Description antonio montagnani 2010-11-16 12:45:01 UTC
abrt version: 1.1.13
architecture: i686
cmdline: python /usr/bin/calibre-parallel
component: calibre
executable: /usr/bin/calibre-parallel
kernel: 2.6.35.6-48.fc14.i686.PAE
package: calibre-0.7.23-1.fc14
reason: writer.py:206:_write:TypeError: __init__() got an unexpected keyword argument 'title'
release: Fedora release 14 (Laughlin)
time: 1289911178
uid: 500

backtrace
-----
writer.py:206:_write:TypeError: __init__() got an unexpected keyword argument 'title'

Traceback (most recent call last):
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 177, in _render_html
    self._render_book()
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 145, in _render_book
    self._write()
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 206, in _write
    outPDF = PdfFileWriter(title=self.metadata.title, author=self.metadata.author)
TypeError: __init__() got an unexpected keyword argument 'title'

Local variables in innermost frame:
self: <calibre.ebooks.pdf.writer.PDFWriter object at 0xa703fac>

How to reproduce
-----
1.exporting to a different format
2.from epub to pdf
3.calibre didn't close

Comment 1 antonio montagnani 2010-11-16 12:45:04 UTC
Created attachment 460828 [details]
File: backtrace

Comment 2 Kevin Fenzi 2010-11-17 04:44:36 UTC
Does the issue happen every time? Does it matter what pdf you export?

Can you try the newer calibre from my side repo: 

cd /etc/yum.repos.d/
wget http://repos.fedorapeople.org/repos/kevin/calibre/fedora-calibre.repo
yum update

Does the problem persist with the newest version?

Comment 3 errio 2010-12-11 17:47:20 UTC
Package: calibre-0.7.23-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Import .chm file
2.calibre crashed
3.


Comment
-----
tried to convert .chm to pdf. Crash happened by importing .chm into the library.

Comment 4 errio 2010-12-11 17:56:41 UTC
Package: calibre-0.7.23-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Closed Calibre after adding .djvu to library
2.calibre crashed
3.


Comment
-----
tried to add .djvu to library Crash happened by importing . djvu into the library.
Reported the crash.
Then tried closing calibre. Another crash happened

Comment 5 holsteynjohan 2010-12-28 12:42:12 UTC
Package: calibre-0.7.23-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Opened Calibre for the first time
2.Setup my iliad in plugins
3.convert a book
4.crash while converting


Comment
-----
tried to converta book from pdf to other pdf

Comment 6 Kevin Fenzi 2011-01-09 19:20:30 UTC
Can you all try the calibre repo from comment 2 and tell me if it persists in the newest version?

Comment 7 Kevin Fenzi 2011-01-09 19:51:08 UTC
*** Bug 616588 has been marked as a duplicate of this bug. ***

Comment 8 Kevin Fenzi 2011-01-09 19:51:15 UTC
*** Bug 601445 has been marked as a duplicate of this bug. ***

Comment 9 Sean Stangl 2011-01-22 05:13:56 UTC
Package: calibre-0.7.23-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Calibre crashes can be reliably reproduced by closing the program by hitting the window manager provided "X" button.

Comment 10 Christian Krause 2011-03-16 23:07:48 UTC
The issue in the original description (problem when converting a book to pdf) is most likely a dupe of:
https://bugzilla.redhat.com/show_bug.cgi?id=673604

Issue mentioned in comment #9 was fixed by calibre-0.7.38-3.fc14.

Comment 11 Christian Krause 2011-03-20 23:49:13 UTC

*** This bug has been marked as a duplicate of bug 673604 ***


Note You need to log in before you can comment on or make changes to this bug.