Bug 616760 - lm_sensors init script missing - regression from beta 1
lm_sensors init script missing - regression from beta 1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lm_sensors (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Nikola Pajkovsky
Michal Nowak
: Regression, RHELNAK
: 611144 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-21 07:32 EDT by Gordan Bobic
Modified: 2014-02-02 17:14 EST (History)
5 users (show)

See Also:
Fixed In Version: lm_sensors-3.1.1-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:06:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.61 KB, patch)
2010-07-21 11:34 EDT, Nikola Pajkovsky
no flags Details | Diff

  None (edit)
Description Gordan Bobic 2010-07-21 07:32:00 EDT
Description of problem:
lm_sensors init script is missing in RHEL6 b2 packages. It was present in b1 lm_sensors package, and is required to load the required drivers at startup time. Without this, the sensors aren't working, and the drivers aren't being loaded.

Version-Release number of selected component (if applicable):
lm_sensors-3.1.1-8.el6.x86_64

Note: the /etc/init.d/lm_sensors file was present in the package in beta 1:
lm_sensors-3.1.1-5.el6.x86_64

Additional info:
I'm not sure if the init script was removed deliberately or not - it seems that there is a drive to make all drivers auto-detect and auto-load. But it clearly isn't working as it should for sensor drivers in most cases, so if the init script was deliberately removed, it should be kept at least until sensors work reliably for most hardware.
Comment 2 RHEL Product and Program Management 2010-07-21 07:57:36 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Nikola Pajkovsky 2010-07-21 08:05:41 EDT
It's not a bug, because init script is only used when you have installed daemon. I've moved init script into lm_sensors-sensord.
Comment 4 Gordan Bobic 2010-07-21 08:50:24 EDT
I don't see the lm_sensors init script in the lm_sensors-sensord package, either. Only the sensord init script is there, same as in the beta 1 package. The two are not the same. I don't think we are talking about the same init script.
Comment 5 Nikola Pajkovsky 2010-07-21 11:34:34 EDT
Created attachment 433449 [details]
proposed patch

Damn, I forgot add a few lines into init script.
Comment 6 Gordan Bobic 2010-07-21 11:42:51 EDT
No, my point is that the two (sensors and sensord)are independent. The lm_sensors init script is supposed to load the drivers, while the sensord init script is supposed to run sensord. The two are separate.

lm_sensors doesn't require sensord, nor should it, but without the lm_sensors init script to load the drivers, sensors won't work.

You are making sensors dependent on sensord, which is non-sensical. Why should sensord be required to run for sensors to work, just for the sake of the same init script loading the drivers? Sensors won't work in the current configuration, which means at best sensors should have a dependency on sensord (for the init script without which it doesn't work). Plus, sensord is in the optional packages, not the core ones.

It wasn't broken, so why is it being "fixed"? What is the gain?
Comment 7 Nikola Pajkovsky 2010-07-21 12:16:18 EDT
(In reply to comment #6)
> No, my point is that the two (sensors and sensord)are independent. The
> lm_sensors init script is supposed to load the drivers, while the sensord init
> script is supposed to run sensord. The two are separate.
> 
Aha, that's why there was almost two same scripts.

> lm_sensors doesn't require sensord, nor should it, but without the lm_sensors
> init script to load the drivers, sensors won't work.
> 
> You are making sensors dependent on sensord, which is non-sensical. Why should
> sensord be required to run for sensors to work, just for the sake of the same
> init script loading the drivers? Sensors won't work in the current
> configuration, which means at best sensors should have a dependency on sensord
> (for the init script without which it doesn't work). Plus, sensord is in the
> optional packages, not the core ones.
> 
> It wasn't broken, so why is it being "fixed"? What is the gain?    

Yes it was, sensord init script doesn't load/unload automatically modules when starts/stops at all.
Comment 8 Gordan Bobic 2010-07-22 04:45:09 EDT
> Yes it was, sensord init script doesn't load/unload automatically modules
> when starts/stops at all.

It isn't supposed to!

sensord service is dependant on lm_sensors service starting before it. In the same way that NFS is dependant on portmap and rpc services. What's wrong with the usual UNIX solution of having the lm_sensors service have a lower priority (earlier startup) than sensord? I still maintain that there was nothing broken to fix.
Comment 9 Nikola Pajkovsky 2010-07-27 08:26:06 EDT
revert changes from lm_sensors-3.1.1-5.el6
Comment 12 Michal Nowak 2010-07-29 08:17:26 EDT
Gordan: I verified lm_sensors init script is back in lm_sensors package. Once beta repositories are refreshed, could you also verify lm_sensors init script is back & working and that the new package satisfied your needs regarding this bug, please?
Comment 13 Gordan Bobic 2010-07-29 08:25:29 EDT
I certainly will, but it may be a few days before my local mirrors are updated.
Comment 14 Nikola Pajkovsky 2010-08-12 04:24:11 EDT
*** Bug 611144 has been marked as a duplicate of this bug. ***
Comment 15 releng-rhel@redhat.com 2010-11-10 16:06:19 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.