Bug 611144 - lm_sensors doesn't load coretemp module automatically
lm_sensors doesn't load coretemp module automatically
Status: CLOSED DUPLICATE of bug 616760
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lm_sensors (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Nikola Pajkovsky
BaseOS QE - Apps
:
Depends On:
Blocks: 623572 623587
  Show dependency treegraph
 
Reported: 2010-07-03 18:49 EDT by David Kovalsky
Modified: 2014-03-31 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 623572 (view as bug list)
Environment:
Last Closed: 2010-08-12 04:24:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/cpuinfo (6.33 KB, application/octet-stream)
2010-07-03 18:49 EDT, David Kovalsky
no flags Details
proposed patch (1.61 KB, patch)
2010-07-21 11:36 EDT, Nikola Pajkovsky
no flags Details | Diff

  None (edit)
Description David Kovalsky 2010-07-03 18:49:22 EDT
Created attachment 429308 [details]
/proc/cpuinfo

For Core i7 processors and running sensors-detect, coretemp module is not loaded automatically and temperatures not shown. If I manually modprobe coretemp, I see the output.

[test@kovinek ~]$ sensors
thinkpad-isa-0000
Adapter: ISA adapter
fan1:       3563 RPM
temp1:       +78.0°C                                    
temp2:        +0.0°C                                    
temp3:        +0.0°C                                    
temp4:        +0.0°C                                    
temp5:        +0.0°C                                    
temp6:        +0.0°C                                    
temp7:        +0.0°C                                    
temp8:        +0.0°C                                    

(coretemp module which I don't see without manually modprobing coretemp)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +76.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0001
Adapter: ISA adapter
Core 1:      +76.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0002
Adapter: ISA adapter
Core 2:      +77.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0003
Adapter: ISA adapter
Core 3:      +77.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0004
Adapter: ISA adapter
Core 4:      +78.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0005
Adapter: ISA adapter
Core 5:      +78.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0006
Adapter: ISA adapter
Core 6:      +77.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0007
Adapter: ISA adapter
Core 7:      +77.0°C  (high = +84.0°C, crit = +100.0°C)  


[test@kovinek ~]$ cat /etc/sysconfig/lm_sensors 
# Generated by sensors-detect on Thu Jul  1 13:38:56 2010
# This file is sourced by /etc/init.d/lm_sensors and defines the modules to
# be loaded/unloaded.
#
# The format of this file is a shell script that simply defines variables:
# HWMON_MODULES for hardware monitoring driver modules, and optionally
# BUS_MODULES for any required bus driver module (for example for I2C or SPI).

HWMON_MODULES="sbs"

# For compatibility reasons, modules are also listed individually as variables
#    MODULE_0, MODULE_1, MODULE_2, etc.
# You should use BUS_MODULES and HWMON_MODULES instead if possible.

MODULE_0=sbs



lm_sensors-3.1.1-8.el6.x86_64
Comment 2 Nikola Pajkovsky 2010-07-07 04:28:11 EDT
Do you have installed lm_sensors-sensord?
Comment 3 David Kovalsky 2010-07-08 08:40:02 EDT
Yes, lm_sensors-sensord-3.1.1-8.el6.x86_64
Comment 4 David Kovalsky 2010-07-08 09:53:53 EDT
Furthermore, even if I set 

HWMON_MODULES="coretemp"
MODULE_0=coretemp

in /etc/sysconfig/lm_sensors

service sensord start doesn't load the module.

Checking the initscript, only sensord is sourced from /etc/sysconfig/. 

It seems like 2 bugs to me:
1) sensors-detect doesn't create a proper config file with coretemp module specified

2) lm_sensors ship a file that isn't used anywhere - /etc/sysconfig/lm_sensors
Comment 5 David Kovalsky 2010-07-08 09:54:41 EDT
/etc/sysconfig/sensord:

# configuration for harware sensors monitoring daemon
# in intevrals use suffix "m" for minutes, "s" for seconds, "h" for hours
# 0 means turning facility off

# interval between scanning alarms
INTERVAL=1m

# interval between logging
LOG_INTERVAL=20m

# interval between RRD logging
# RRD_INTERVAL=1m

# RRD db location
# RRD_LOGFILE=/var/log/sensors.rrd
Comment 6 David Kovalsky 2010-07-08 10:01:00 EDT
If it makes a difference, I ran sensors-detect before installing lm_sensors-sensord.

Issues mentioned above don't seem to be limited only to Core i7, raising priority.
Comment 7 Nikola Pajkovsky 2010-07-21 11:36:36 EDT
Created attachment 433450 [details]
proposed patch

Damn, I forgot add a few lines into init script.
Comment 8 Nikola Pajkovsky 2010-08-12 04:24:11 EDT

*** This bug has been marked as a duplicate of bug 616760 ***

Note You need to log in before you can comment on or make changes to this bug.