Bug 616859 - Guest cpu cores doesn't match with qemu argument
Guest cpu cores doesn't match with qemu argument
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: Regression
Depends On:
Blocks: 580945
  Show dependency treegraph
 
Reported: 2010-07-21 10:56 EDT by Amos Kong
Modified: 2015-05-24 20:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 22:24:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amos Kong 2010-07-21 10:56:28 EDT
Description of problem:
Boot up rhel4 guest with '-smp 2', but there is only 1 core in guest.
This bug doesn't exist on qemu-kvm-0.12.1.2-2.93.el6.x86_64


Version-Release number of selected component (if applicable):
host kernel: 2.6.32-44.1.el6.x86_64
guest kernel: 2.6.9-89.EL
qemu-kvm-0.12.1.2-2.96.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1. boot up rhel4 guest with '-smp 2'
2. check cpu cores on guest
# cat /proc/cpuinfo
  
Actual results:
guest has only 1 cpu core

Expected results:
guest has two cpu cores

Additional info:
guest) # cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 2
model name      : QEMU Virtual CPU version 0.12.1
stepping        : 3
cpu MHz         : 2660.238
cache size      : 4096 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 4
wp              : yes
flags           : fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx lm pni cx16 lahf_lm
bogomips        : 5330.60
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management:

Qemu cmdline:
# qemu-kvm -name 'vm1' -monitor unix:'/tmp/monitor-humanmonitor1-20100721-223536-AqCT',server,nowait -serial unix:'/tmp/serial-20100721-223536-AqCT',server,nowait -drive file='/home/devel/push/client/tests/kvm/images/RHEL-4.8-64.qcow2',if=none,id=drive-ide0-0-0,media=disk,cache=none,format=qcow2 -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -net nic,vlan=0,netdev=idk93s3f,model=e1000,macaddr='02:A9:7C:6C:c9:6b' -netdev tap,id=idk93s3f,ifname='e1000_0_8000',script='/home/devel/push/client/tests/kvm/scripts/qemu-ifup-switch',downscript='no' -m 512 -smp 2 -vnc :0 -spice port=8000,disable-ticketing -vga qxl -rtc base=utc,clock=host -M rhel6.0.0 -usbdevice tablet -cpu qemu64,+sse2 -no-kvm-pit-reinjection
Comment 3 Alex Williamson 2010-07-21 19:17:21 EDT
(In reply to comment #0)
> guest kernel: 2.6.9-89.EL

It better be 2.6.9-89.ELsmp if you expect to see more than one CPU.  Please retest and verify smp guest kernel.
Comment 4 Amos Kong 2010-07-21 22:17:35 EDT
(In reply to comment #3)
> (In reply to comment #0)
> > guest kernel: 2.6.9-89.EL
> 
> It better be 2.6.9-89.ELsmp if you expect to see more than one CPU.  Please
> retest and verify smp guest kernel.    

Oh, so careless.
After updated kernel to 2.6.9-89.29.ELsmp, could not reproduce.
So you can close this bug.

Note You need to log in before you can comment on or make changes to this bug.