This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 580945 - Add HLT instruction emulation to VMXAssist in Xen
Add HLT instruction emulation to VMXAssist in Xen
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.5
All Linux
low Severity urgent
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
: ZStream
: 591475 (view as bug list)
Depends On: 616859
Blocks: 506924 570496 593230
  Show dependency treegraph
 
Reported: 2010-04-09 10:43 EDT by Michal Novotny
Modified: 2014-02-02 17:37 EST (History)
13 users (show)

See Also:
Fixed In Version: xen-3.0.3-108.el5
Doc Type: Bug Fix
Doc Text:
Due to the missing HLT (halt) instruction emulation in the VMXAssist real-mode emulator, certain versions of the SYSLINUX boot loader could have caused the guest operating system (domU) to stop responding. With this update, the HLT instruction emulation has been added, and all versions of SYSLINUX now boot properly.
Story Points: ---
Clone Of: 570496
Environment:
Last Closed: 2011-01-13 17:21:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to add HLT instruction emulation support (924 bytes, patch)
2010-04-09 11:03 EDT, Michal Novotny
no flags Details | Diff
New version of HLT instruction emulation support patch (483 bytes, patch)
2010-04-12 05:19 EDT, Michal Novotny
no flags Details | Diff

  None (edit)
Comment 1 Michal Novotny 2010-04-09 11:03:57 EDT
Created attachment 405569 [details]
Patch to add HLT instruction emulation support

This is the patch to add HLT instruction emulation support to VMXAssist in Xen. It basically adds HLT opcode (0xF4) to the emulated opcodes for vm86. This allows emulated real-mode use halt instruction without hanging the guest.

Michal
Comment 4 Michal Novotny 2010-04-12 05:19:35 EDT
Created attachment 405915 [details]
New version of HLT instruction emulation support patch

This is the new version of HLT instruction emulation support patch for VMXAssist not adding fetch8() part to VMXAssist panic if the instruction is unknown since it could return bad EIP since fetch8() function increments the instruction pointer.

Michal
Comment 8 Miroslav Rezanina 2010-05-12 07:35:26 EDT
*** Bug 591475 has been marked as a duplicate of this bug. ***
Comment 11 Jaromir Hradilek 2010-07-07 04:55:28 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Due to the missing HLT (halt) instruction emulation in the VMXAssist real-mode emulator, certain versions of the SYSLINUX boot loader could have caused the guest operating system (domU) to stop responding. With this update, the HLT instruction emulation has been added, and all versions of SYSLINUX now boot properly.
Comment 15 errata-xmlrpc 2011-01-13 17:21:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0031.html

Note You need to log in before you can comment on or make changes to this bug.