Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617008 - [abrt] evolution-2.28.3-8.el6: raise: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
[abrt] evolution-2.28.3-8.el6: raise: Process /usr/bin/evolution was killed b...
Status: CLOSED DUPLICATE of bug 603215
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
abrt_hash:8700b6e4b919b4db20bb774f425...
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-21 17:42 EDT by Ben Woodard
Modified: 2010-07-22 04:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 04:30:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (60.35 KB, text/plain)
2010-07-21 17:42 EDT, Ben Woodard
no flags Details

  None (edit)
Description Ben Woodard 2010-07-21 17:42:52 EDT
abrt version: 1.1.10
architecture: x86_64
Attached file: backtrace
cmdline: evolution
component: evolution
crash_function: raise
executable: /usr/bin/evolution
kernel: 2.6.32-42.el6.x86_64
package: evolution-2.28.3-8.el6
rating: 4
reason: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
time: 1279748498
uid: 500

How to reproduce
-----
1. Another poof crash. Was just using email and poof evo died.
2.
3.
Comment 1 Ben Woodard 2010-07-21 17:42:54 EDT
Created attachment 433524 [details]
File: backtrace
Comment 2 Ben Woodard 2010-07-21 17:43:51 EDT
might be related to 617005 both happened within a few minutes of each other.
Comment 3 Ben Woodard 2010-07-21 17:46:33 EDT
Package: evolution-2.28.3-8.el6
Architecture: x86_64
OS Release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)


How to reproduce
-----
1. 3rd time it crashed in a few minutes.
2. was reading email with vpn down and after a few minutes the client went poof.
3.
Comment 4 Ben Woodard 2010-07-21 17:49:50 EDT
Program received signal SIGSEGV, Segmentation fault.
camel_msgport_try_pop (msgport=0x7e5e5e5e5e5e572) at camel-msgport.c:402
402		g_async_queue_lock (msgport->queue);
Missing separate debuginfos, use: debuginfo-install PackageKit-gtk-module-0.5.8-8.el6.x86_64 avahi-glib-0.6.25-8.el6.x86_64 avahi-libs-0.6.25-8.el6.x86_64 bluez-libs-4.66-1.el6.x86_64 bzip2-libs-1.0.5-6.1.el6.x86_64 cyrus-sasl-lib-2.1.23-8.el6.x86_64 db4-4.7.25-16.el6.x86_64 evolution-mapi-0.28.3-5.el6.x86_64 expat-2.0.1-9.1.el6.x86_64 gnome-keyring-2.28.2-5.el6.x86_64 gnutls-2.8.5-4.el6.x86_64 gtk2-engines-2.18.4-5.el6.x86_64 gvfs-1.4.3-9.el6.x86_64 keyutils-libs-1.4-1.el6.x86_64 libXau-1.0.5-1.el6.x86_64 libXcomposite-0.4.1-2.el6.x86_64 libXcursor-1.1.10-2.el6.x86_64 libXdamage-1.1.2-1.el6.x86_64 libXext-1.1-3.el6.x86_64 libXfixes-4.0.4-1.el6.x86_64 libXi-1.3-3.el6.x86_64 libXinerama-1.1-1.el6.x86_64 libXrandr-1.3.0-4.el6.x86_64 libXrender-0.9.5-1.el6.x86_64 libcanberra-0.22-1.el6.x86_64 libcanberra-gtk2-0.22-1.el6.x86_64 libcroco-0.6.2-5.el6.x86_64 libgcrypt-1.4.5-3.el6.x86_64 libgpg-error-1.7-3.el6.x86_64 libgsf-1.14.15-5.el6.x86_64 libldb-0.9.10-23.el6.x86_64 libogg-1.1.4-2.1.el6.x86_64 libpng-1.2.44-1.el6.x86_64 librsvg2-2.26.0-5.el6.x86_64 libtalloc-2.0.1-1.1.el6.x86_64 libtasn1-2.3-3.el6.x86_64 libtdb-1.2.1-2.el6.x86_64 libtevent-0.9.8-8.el6.x86_64 libtool-ltdl-2.2.6-15.5.el6.x86_64 libudev-147-2.21.el6.x86_64 libusb-0.1.12-23.el6.x86_64 libvorbis-1.2.3-4.el6.x86_64 libxcb-1.5-1.el6.x86_64 openchange-0.9-7.el6.x86_64 openssl-1.0.0-4.el6.x86_64 pixman-0.16.6-1.el6.x86_64 samba4-libs-4.0.0-23.alpha11.el6.x86_64 xcb-util-0.3.6-1.el6.x86_64 zlib-1.2.3-25.el6.x86_64
(gdb) bt
#0  camel_msgport_try_pop (msgport=0x7e5e5e5e5e5e572) at camel-msgport.c:402
#1  0x00000030e7444654 in camel_operation_cancel_check (cc=0x344b730) at camel-operation.c:405
#2  0x00007fffeee259b1 in regen_list_done (m=0x3424d10) at message-list.c:4232
#3  0x00007fffeeb99821 in mail_msg_idle_cb () at mail-mt.c:502
#4  0x00000030ce038f0e in g_main_dispatch (context=0x66d550) at gmain.c:1960
#5  IA__g_main_context_dispatch (context=0x66d550) at gmain.c:2513
#6  0x00000030ce03c938 in g_main_context_iterate (context=0x66d550, block=1, dispatch=1, 
    self=<value optimized out>) at gmain.c:2591
#7  0x00000030ce03cd55 in IA__g_main_loop_run (loop=0x6e1db0) at gmain.c:2799
#8  0x00000030dfc2d106 in bonobo_main () at bonobo-main.c:311
#9  0x000000000041569a in main (argc=<value optimized out>, argv=<value optimized out>) at main.c:732

I just had deleted the last message.
Comment 5 Ben Woodard 2010-07-21 17:57:20 EDT
once I restarted the VPN, evo seems to be staying up.
Comment 7 Ben Woodard 2010-07-21 18:16:05 EDT
Program received signal SIGPIPE, Broken pipe.
[Switching to Thread 0x7fffe365d710 (LWP 12398)]
0x00000030cec0ea8c in __libc_send (fd=<value optimized out>, buf=<value optimized out>, 
    n=<value optimized out>, flags=<value optimized out>) at ../sysdeps/unix/sysv/linux/x86_64/send.c:33
33					   (size_t) 0);
Missing separate debuginfos, use: debuginfo-install hunspell-1.2.8-16.el6.x86_64
(gdb) bt
#0  0x00000030cec0ea8c in __libc_send (fd=<value optimized out>, buf=<value optimized out>, 
    n=<value optimized out>, flags=<value optimized out>) at ../sysdeps/unix/sysv/linux/x86_64/send.c:33
#1  0x00000030e1026fed in pt_Send (fd=0x19458d0, buf=0x194f9f0, amount=37, flags=0, timeout=4294967295)
    at ../../../mozilla/nsprpub/pr/src/pthreads/ptio.c:1931
#2  0x00000030e30195ab in ssl_DefSend (ss=0x1946200, buf=0x194f9f0 "\025\003", len=37, flags=0) at ssldef.c:127
#3  0x00000030e300a554 in ssl3_SendRecord (ss=0x1946200, type=content_alert, pIn=<value optimized out>, 
    nIn=<value optimized out>, flags=0) at ssl3con.c:2280
#4  0x00000030e300a98f in SSL3_SendAlert (ss=0x1946200, level=<value optimized out>, desc=close_notify)
    at ssl3con.c:2535
#5  0x00000030e301d318 in ssl_SecureShutdown (ss=0x1946200, nsprHow=2) at sslsecur.c:1093
#6  0x00000030e3021f19 in ssl_Shutdown (fd=<value optimized out>, how=2) at sslsock.c:1526
#7  0x00000030eb84b42a in stream_close (stream=0x13f0200) at camel-tcp-stream-ssl.c:525
#8  0x00007fffe9d5cf53 in imap_disconnect (service=<value optimized out>, clean=0, ex=<value optimized out>)
    at camel-imap-store.c:1557
#9  0x00000030eb841181 in camel_service_disconnect (service=0x8e1890, clean=0, ex=0x0) at camel-service.c:426
#10 0x00007fffe9d4f285 in imap_command_start (store=0x8e1890, folder=0x0, cmd=<value optimized out>, ex=
    0x7fffe365cca0) at camel-imap-command.c:234
#11 0x00007fffe9d4efea in camel_imap_command (store=0x8e1890, folder=0x0, ex=0x7fffe365cca0, 
    fmt=<value optimized out>) at camel-imap-command.c:109
#12 0x00007fffe9d50b4d in do_append (folder=0x1f37030, message=<value optimized out>, info=0x326f700, uid=
    0x7fffe365cb68, ex=0x7fffe365cca0) at camel-imap-folder.c:1970
#13 0x00007fffe9d576a5 in imap_append_online (folder=0x1f37030, message=0x8de2e0, info=0x326f700, appended_uid=
    0x0, ex=0x7fffe365cca0) at camel-imap-folder.c:2044
#14 0x00000030eb82f661 in camel_folder_append_message (folder=0x1f37030, message=0x8de2e0, info=0x326f700, 
    appended_uid=0x0, ex=0x7fffe365cca0) at camel-folder.c:714
#15 0x00007fffeeb96977 in mail_send_message (m=0x3ad5030) at mail-ops.c:586
#16 send_queue_exec (m=0x3ad5030) at mail-ops.c:741
#17 0x00007fffeeb9915f in mail_msg_proxy (msg=0x3ad5030) at mail-mt.c:522
#18 0x00000030ce06360b in g_thread_pool_thread_proxy (data=<value optimized out>) at gthreadpool.c:265
#19 0x00000030ce062074 in g_thread_create_proxy (data=0x414ef70) at gthread.c:635
#20 0x00000030cec077e1 in start_thread (arg=0x7fffe365d710) at pthread_create.c:301
#21 0x00000030ce4e151d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
Comment 8 RHEL Product and Program Management 2010-07-21 18:18:01 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 9 Milan Crha 2010-07-22 04:30:42 EDT
Thanks for a bug report. The original abrt report is a duplicate of bug #603215, the comment #4 is a duplicate of bug #602667 and the last one, comment #7, it isn't a crash, I suppose, as this signal is usually recoverable.

*** This bug has been marked as a duplicate of bug 603215 ***

Note You need to log in before you can comment on or make changes to this bug.