Bug 617274 - [RFE] all tasks should have an owner
[RFE] all tasks should have an owner
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: tests (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: 0.7.01
: ---
Assigned To: Dan Callaghan
:
: 593798 660636 674695 (view as bug list)
Depends On:
Blocks: 624417
  Show dependency treegraph
 
Reported: 2010-07-22 12:16 EDT by Ales Zelinka
Modified: 2012-01-31 23:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-07 22:43:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2010-07-22 12:16:35 EDT
Description of problem:
For accountability reasons, Beaker should reject tasks without an owner (just like it rejects tasks without license). Without an owner, there is no one to contact if there are problems with the test.
Comment 1 Dan Callaghan 2011-08-01 01:11:50 EDT
I have a patch for Beaker to record uploader and owner for newly uploaded tasks. It will refuse to accept tasks without an Owner field. I also have a patch for rhts-devel so that rhts-lint will complain about missing Owner field.

Patches pushed to Gerrit for review.
Comment 2 Dan Callaghan 2011-08-01 01:28:56 EDT
*** Bug 674695 has been marked as a duplicate of this bug. ***
Comment 3 Bill Peck 2011-08-23 12:53:19 EDT
The client change has been pushed into rhts-devel-4.39-1

to test please use beaker-stage repo

yum upgrade --enablerepo=beaker-stage rhts\*

But you will need to wait for the server side to be updated as well.

This bz will move to ONQA when the server side is ready.
Comment 8 Bill Peck 2011-09-02 10:03:14 EDT
The webUI needs to catch that exception and pass it to flash() so that the user sees why the upload couldn't be accepted.
Comment 9 Dan Callaghan 2011-09-05 02:32:53 EDT
Agreed, friendly exception handling will be added to the web UI.
Comment 11 Dan Callaghan 2011-09-07 22:43:11 EDT
Beaker 0.7.1 has been released.
Comment 12 Dan Callaghan 2011-10-26 23:35:29 EDT
*** Bug 660636 has been marked as a duplicate of this bug. ***
Comment 13 Dan Callaghan 2012-01-31 23:20:30 EST
*** Bug 593798 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.