Bug 617296 - jabberd2 is not available in current version
jabberd2 is not available in current version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jabberd (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
:
: 621949 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 13:26 EDT by Dominic Hopf
Modified: 2010-10-19 03:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: jabberd-2.2.11-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-18 01:38:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominic Hopf 2010-07-22 13:26:46 EDT
The package of jabberd2 is not current in Fedora 13. The available package is jabberd-2.2.8-5.fc12.x86_64, upstream already provides 2.2.10 since the beginning of June, see http://codex.xiaoka.com/wiki/jabberd2:start

I can support you as Co-Maintainer if you like.
Comment 1 Bernie Innocenti 2010-07-22 23:16:34 EDT
(In reply to comment #0)
> The package of jabberd2 is not current in Fedora 13. The available package is
> jabberd-2.2.8-5.fc12.x86_64, upstream already provides 2.2.10 since the
> beginning of June, see http://codex.xiaoka.com/wiki/jabberd2:start
> 
> I can support you as Co-Maintainer if you like.    

I'd be happy to pass maintainership of jabberd to you... what's your FAS name?
Comment 2 Dominic Hopf 2010-07-23 07:09:45 EDT
You will find me as "dmaphy" in FAS. :)
Comment 3 Bernie Innocenti 2010-07-23 11:14:55 EDT
(In reply to comment #2)
> You will find me as "dmaphydmaphy" in FAS. :)    

I just realized I had already passed maintainership of jabberd to adrian a while ago:

  https://admin.fedoraproject.org/pkgdb/acls/name/jabberd

While we're waiting for Adrian to respond, why don't you go ahead and request ACLs on the package?
Comment 4 Adrian Reber 2010-07-24 06:32:13 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > You will find me as "dmaphydmaphy" in FAS. :)    
> 
> I just realized I had already passed maintainership of jabberd to adrian a
> while ago:

and I thought you took it over from me ;-)

> While we're waiting for Adrian to respond, why don't you go ahead and request
> ACLs on the package?    

I approved your requests and I am happy yor are interested in jabberd2. The problem with jabberd2 is that upgrades are not always 100% compatible with the previous version. Until now there were never any real problems... Just wanted to let you know.
Comment 5 Dominic Hopf 2010-07-24 06:46:21 EDT
Okay, good to know. I'll have a deeper look at the package today. :)
Comment 6 Dominic Hopf 2010-08-01 19:31:35 EDT
Just for completeness: I already have a new package lying around locally, I'll try to get this online within the coming week. :)
Comment 7 Dominic Hopf 2010-08-08 18:15:12 EDT
*** Bug 621949 has been marked as a duplicate of this bug. ***
Comment 8 Dominic Hopf 2010-09-12 10:32:02 EDT
For those interested I already have an update now:

http://dmaphy.fedorapeople.org/jabberd2/

Be careful with upgrading and backup your configuration files, even if they're not be overwritten. You most  likely will find either *.rpmsave or *.rpmnew files in /etc/jabberd/ and have to have a look at the changes yourself.

I'm sorry for the delay in providing this update, just began a new job in July and there is much to do... I guess you know that. ;)

I think I will provide this update for Rawhide first and will push it to F14 and F13, if I get positive feedback concerning the update in Rawhide.
Comment 9 Fedora Update System 2010-10-06 19:58:25 EDT
jabberd-2.2.11-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/jabberd-2.2.11-2.fc13
Comment 10 Fedora Update System 2010-10-06 19:58:33 EDT
jabberd-2.2.11-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/jabberd-2.2.11-2.fc14
Comment 11 Dominic Hopf 2010-10-06 20:00:47 EDT
I'd appreciate any tests and feedback to the update system. :)
Comment 12 Adrian Reber 2010-10-07 02:58:14 EDT
I have not tested it yet, but seeing as you seem to have changed the default storage backend from berkley db to sqlite I would expect problems during the upgrade. I would not recommend changing the default backend during a release (in this case Fedora 13, probably also Fedora 14). I would change it in development and with the next new Fedora release I would release a new jabberd version with a new storage backend.
Comment 13 Fedora Update System 2010-10-07 15:55:11 EDT
jabberd-2.2.11-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jabberd'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/jabberd-2.2.11-2.fc14
Comment 14 Dominic Hopf 2010-10-07 16:40:06 EDT
Well, since configuration files and existing data isn't overridden, I don't see a danger that anything might crash. Do you think it's too confusing for users when they set up a new jabber configuration? Sooner or later they would have to face this change I guess.

I must admit, I maybe was a bit too tired last night and forgot to explicitly write a hint about the change to the new default database, even if it was my plan before. :s

If you think it is worth to revoke the update request, please let me know.
Comment 15 Adrian Reber 2010-10-08 03:01:51 EDT
(In reply to comment #14)
> If you think it is worth to revoke the update request, please let me know.

I just wanted to mention it to make sure it has not been overlooked. It does not sound like it needs to be revoked.
Comment 16 Dominic Hopf 2010-10-10 07:35:49 EDT
Just noted bodhi provides possibility to edit updates. Thus I added the following paragraph to the update notes:

-----
Note this update changes the default backend from BDB to SQLite. Thus if you're setting up a new Jabber service with this package, have an eye on this.

You're also recommended to diff and review your configuration files manually.
-----

Hope this prevents unnecessary confusion. :)
Comment 17 Fedora Update System 2010-10-18 01:38:33 EDT
jabberd-2.2.11-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-10-19 03:19:34 EDT
jabberd-2.2.11-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.