Bug 61739 - modules in php-4.1.2-3 will never get enabled
modules in php-4.1.2-3 will never get enabled
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: php (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
: 62104 (view as bug list)
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-23 16:56 EST by Konstantin Ryabitsev
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 11:56:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch which fixes the module enabling routines (3.34 KB, patch)
2002-03-23 16:57 EST, Konstantin Ryabitsev
no flags Details | Diff

  None (edit)
Description Konstantin Ryabitsev 2002-03-23 16:56:38 EST
Description of Problem:

looking at the .spec file....
%{__perl} -pi -e "s|^;extension=pgsql.dll|extension=pgsql.so|" \
%{_sysconfdir}/php.ini

this will never enable the module, since the line it's looking for in
/etc/php.ini is ";extension=php_pgsql.dll".

A more complicated problem is with php-mysql and php-odbc. /etc/php.ini doesn't
contain dll extensions for those, since they are linked statically to the main
php4 dll. However, I have a patch which fixes this problem.
Comment 1 Konstantin Ryabitsev 2002-03-23 16:57:44 EST
Created attachment 49864 [details]
patch which fixes the module enabling routines
Comment 2 Phil Copeland 2002-03-26 14:23:15 EST
Doh,...
Always miss something when I'm in a rush.

Thanks..
it's in as of 4.1.2-4

Phil
=--=


Comment 3 Phil Copeland 2002-03-28 14:26:08 EST
*** Bug 62104 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.