Bug 62104 - php.ini issues
Summary: php.ini issues
Status: CLOSED DUPLICATE of bug 61739
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: php   
(Show other bugs)
Version: skipjack-beta1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-03-27 15:46 UTC by Christopher McCrory
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 15:06:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pixes php.ini (5.20 KB, patch)
2002-03-27 15:49 UTC, Christopher McCrory
no flags Details | Diff

Description Christopher McCrory 2002-03-27 15:46:00 UTC
Description of Problem:
php.ini has 'issues'

Version-Release number of selected component (if applicable):
php-4.1.2-3

How Reproducible:
always

Steps to Reproduce:
1. install php
2. 
3. 

Actual Results:
broken php.ini

Expected Results:
working php.ini   :)

Additional Information:
from spec:
- Some wassak upstream changed the default php.ini file to
  winblows format (.dll) which broke the extension munching
  altered the post scripts to accomodate (#59195)

IIRC, they were always .dlls, the .so stuff was a redhat patch

This will generate the entries:
[chrismcc]$ for EXT in $(ls|grep -v 'ext_skel\|Makefile.in') ; do echo
";extension=${EXT}.so" ;done

;extension=aspell.so
;extension=bcmath.so
;extension=bz2.so
;extension=calendar.so
;extension=ccvs.so
;extension=com.so
;extension=cpdf.so
;extension=crack.so
;extension=ctype.so
;extension=curl.so

This adds all the possible extensions.  That way someone could write another php
rpm (like mhash) and the %post %__perl tricks will work for it.

For instance, the mysql entry is missing.

I also ran into a ./configure bug ? where I had a ~/bin/sendmail.  When I
rebuilt the rpm php picked up /home/chrismcc/bin/sendmail as the sendmail path.
 this only existed on this one machine.  hence mail broke on the other machines.

./configure PROG_SENDMAIL=/usr/bin/sendmail

fixed it.  This was really a me specific thing, but I thought I'd through it in.


http://bugs.php.net/bug.php?id=16311 is the php bugid I created for the php.ini
thing.

Comment 1 Christopher McCrory 2002-03-27 15:49:50 UTC
Created attachment 50885 [details]
pixes php.ini

Comment 2 Konstantin Ryabitsev 2002-03-28 15:05:58 UTC
This is fixed. Please see:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=61739

Comment 3 Phil Copeland 2002-03-28 19:26:14 UTC

*** This bug has been marked as a duplicate of 61739 ***


Note You need to log in before you can comment on or make changes to this bug.