Bug 617435 - guest->host and host->guest packets have wrong checksums when tx offload is on
guest->host and host->guest packets have wrong checksums when tx offload is on
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win (Show other bugs)
5.6
All Linux
high Severity high
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
: TestBlocker
Depends On:
Blocks: 518405 731293
  Show dependency treegraph
 
Reported: 2010-07-22 23:06 EDT by Pengzhen Cao
Modified: 2011-08-17 05:53 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.3.0-1
Doc Type: Bug Fix
Doc Text:
Previously, the communication between the windows guest and the host or other guests on the same host failed if packet checksum offloading was turned on in the other machine. With this update, the guest can reliably communicate with the host or with other guests on the same host.
Story Points: ---
Clone Of:
: 731293 (view as bug list)
Environment:
Last Closed: 2011-02-01 04:00:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Paolo Bonzini 2010-07-26 14:54:05 EDT
The connection actually begins, but it gets stuck very soon.
Comment 7 Paolo Bonzini 2010-08-04 11:31:43 EDT
Is this still a test blocker?
Comment 8 Pengzhen Cao 2010-08-04 22:05:03 EDT
(In reply to comment #7)
> Is this still a test blocker?    

Yes, our automated test frame work needs to log into the guest vm with "ssh" during test.And we also need PV driver to be functional to do migration andsave/restore test.

Although disable the nic's tx checksum offload feature manually can work around this bug, it is not convenient to do so with automated test, especially when do migration test with multiple machines.
Comment 9 Paolo Bonzini 2010-08-05 10:48:30 EDT
Moving this to kernel.  If it works with tun/tap but not with PV NICs, the bug is likely in netback and latent for Linux guests too.
Comment 10 Paolo Bonzini 2010-08-12 09:48:35 EDT
Michael's patch at <20100711164454.GA9707@redhat.com> (bug 605555) may help here.
Comment 11 Paolo Bonzini 2010-09-03 06:11:57 EDT
Can you test with other NICs?  If it's a problem only with Broadcom, it's possible to blacklist those when picking a machine.  Alternatively, you can prepare an rpm with a /sbin/ifup-local file like

#! /bin/sh
if [ "$1" = eth0 ]; then
  ethtool -K $1 tx off
fi

and install that.

(That said, I do want to fix this since I'm currently working around it on my machine too)
Comment 12 Paolo Bonzini 2010-09-03 07:38:05 EDT
By the way, I tried also guest->host packets sent by a Linux guest, and they also have a wrong checksum (so they cannot communicate with Windows guests); again, "ethtool -K eth0 tx off" in the guest fixes it.
Comment 15 Florian Nadge 2010-10-18 12:28:50 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the communication between the windows guest and the host or other guests on the same host failed if packet checksum offloading was turned on in the other machine. With this update, the guest can reliably communicate with the host or with other guests on the same host.
Comment 16 YangGuang 2010-10-21 22:40:11 EDT
Version-Release number of selected component (if applicable):
xenpv-win-1.2.0-1.el5.noarch
xen-3.0.3-114.el5
kernel-xen-2.6.18-207.el5
guest: Windows2003 32-bit

Steps to Reproduce:
1. install a windows guest and then install pvwin drivers in it
2. using winscp or ftp client tools to access the host where the guest is on
3. install rss(a tiny ssh server) in guest, connect to it with nc from the host
where the guest is on

Detailed results:
1. these conncetion does not hang there and works well.
Comment 17 YangGuang 2010-10-21 22:44:34 EDT
Version-Release number of selected component (if applicable):
Update xenpv-win to 1.3.0-1
The others are same as comment#16

Steps to Reproduce:
same as comment#16

Detailed results:
1. these conncetion does not hang there and works well.


These is no problem with old build, and verified no issue with the new build.
Change it to verified.
Comment 18 errata-xmlrpc 2011-02-01 04:00:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0187.html

Note You need to log in before you can comment on or make changes to this bug.