Bug 617593 - anaconda backtraces because pyblock does not create a device node for the ext. partition
anaconda backtraces because pyblock does not create a device node for the ext...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-pyblock (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
anaconda_trace_hash:2d98a8b7f93a63c3b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 09:59 EDT by Hans de Goede
Modified: 2010-11-10 16:23 EST (History)
3 users (show)

See Also:
Fixed In Version: python-pyblock-0.48-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 617337
Environment:
Last Closed: 2010-11-10 16:23:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-07-23 09:59:17 EDT
+++ This bug was initially created as a clone of Bug #617337 +++

The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 787, in destroyDevice
    if device.format.exists and device.format.type:
  File "/usr/lib/anaconda/storage/partitioning.py", line 390, in removeEmptyExtendedPartitions
    storage.destroyDevice(extended)
  File "/usr/lib/anaconda/storage/partitioning.py", line 378, in clearPartitions
    removeEmptyExtendedPartitions(storage)
  File "/usr/lib/anaconda/storage/partitioning.py", line 183, in doAutoPartition
    clearPartitions(anaconda.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'format'

--- Additional comment from mauricepijpers@yahoo.com on 2010-07-22 15:21:34 EDT ---

Created an attachment (id=433792)
Attached traceback automatically from anaconda.

--- Additional comment from mauricepijpers@yahoo.com on 2010-07-22 15:31:54 EDT ---

System uses 1 ATA/IDE disk which contains grub and a Windows partition and 2 SATA disk in an nvidia_raid that contains a Fedora 11 installation. Whenever the nvidia raid is selected for installation the installer stop with the attached messages.

--- Additional comment from hdegoede@redhat.com on 2010-07-23 09:53:55 EDT ---

Hi,

Thanks for the bug report!

Note to self here is what happening:

1) Due to the fix for bug 583484:
http://git.fedorahosted.org/git/?p=pyblock.git;a=commitdiff;h=030c578f061509022e4db5136149be173b16139d
pyblock no longer creates a mapping, and thus a device node for the extended partition itself
2) This means the extended partition does not get added to the device tree
3) This causes this backtrace when auto-partitioning tries to remove the extended partition (as after clearing partitions it is empty).

Solution:

Make pyblock create a mapping for extended partitions again, but this time one which is compatible with kpartx's mapping to avoid bug 583484.

I hope that your nvidia raid is still in the condition which triggers this fault, I'll provide you with an updates.img with a proposed fix to test this.

Regards,

Hans
Comment 2 Hans de Goede 2010-07-25 04:46:37 EDT
This is fixed in python-pyblock-0.48-1.el6, moving to modified.
Comment 7 releng-rhel@redhat.com 2010-11-10 16:23:25 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.