Bug 61775 - error msgs from redhat-config-users
Summary: error msgs from redhat-config-users
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 61861 (view as bug list)
Depends On:
Blocks: 61901
TreeView+ depends on / blocked
 
Reported: 2002-03-24 13:36 UTC by Gene Czarcinski
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 20:59:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error (warning) msgs from redhat-config-users (3.48 KB, text/plain)
2002-03-24 13:37 UTC, Gene Czarcinski
no flags Details

Description Gene Czarcinski 2002-03-24 13:36:18 UTC
Description of Problem:
On a fresh install of beta3 (unlike bug 61748), I get error messages when
redhat-config-users is started.  This does not appear to cause problems during
execution.

Version-Release number of selected component (if applicable):
beta3

How Reproducible:
everytime

Steps to Reproduce:
1. fresh install of beta3
2. login as root
3. from terminal window, run redhat-config-users

Actual Results:
get error messages (captured via 2>xx)


Expected Results:
no msgs

Additional Information:
	
msgs attached

Comment 1 Gene Czarcinski 2002-03-24 13:37:05 UTC
Created attachment 49964 [details]
error (warning) msgs from redhat-config-users

Comment 2 Brent Fox 2002-03-25 15:48:30 UTC
I've been seeing these warning messages for a while now with pygtk2/libglade2,
and I don't really know what they mean.  It's complaining about not finding a
handler for the signals that various widgets create, but the handlers are
obviously there since clicking on the buttons actually does something.

I've emailed the maintainer of pygtk2/libglade2 to see if he knows.  We'll see
what he says.

Comment 3 Brent Fox 2002-03-25 16:15:45 UTC
*** Bug 61861 has been marked as a duplicate of this bug. ***

Comment 4 Brent Fox 2002-03-26 20:59:02 UTC
He says:

"There was a bug in the last pygtk release (1.99.8) where it would decref a
reference it didn't own in the signal_autoconnect() wrapper.  This is probably
the cause of the problem you are seeing.  Either try checking out CVS head, or
editing libglade.override and get rid of the Py_DECREF call just before the
g_signal_connect_closure() call in connect_many()."

Comment 5 Brent Fox 2002-04-03 22:29:53 UTC
msw has built a new pygtk2 that pulls in these changes and doesn't spew all the
handler warnings.  The deprecation warnings will still be there though.  There
doesn't seem to be a way to avoid them at the moment.


Note You need to log in before you can comment on or make changes to this bug.