Bug 617827 - [abrt] crash in system-config-printer-1.2.3-3.fc13: in cups_array_find()
[abrt] crash in system-config-printer-1.2.3-3.fc13: in cups_array_find()
Status: CLOSED DUPLICATE of bug 612078
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:63a8082513b39d62fd2b58bb358...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-24 05:42 EDT by Dirk Foerster
Modified: 2010-09-13 04:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 04:55:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (91.84 KB, text/plain)
2010-07-24 05:42 EDT, Dirk Foerster
no flags Details

  None (edit)
Description Dirk Foerster 2010-07-24 05:42:19 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: python /usr/share/system-config-printer/system-config-printer.py
comment: It was not possible in system-config-printer 1.2.3 to use the already installed driver for hp Deskjet F2420. There was no option to finish setup.
component: system-config-printer
crash_function: __strcmp_sse2
executable: /usr/bin/python
global_uuid: 63a8082513b39d62fd2b58bb3582ab9700d40a94
kernel: 2.6.33.6-147.fc13.x86_64
package: system-config-printer-1.2.3-3.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.In system-config-printer 1.2.3 go to server=>printer=>new printer. Allow firewall to be configured to search for network printers.
2.Select local hp Deskjet F2420. Allow for driver to be looked up. Message informs driver is already installed. No option to finish setup. Therefore abort and leave setup.
3.In server chose connect. Application crashes.
Comment 1 Dirk Foerster 2010-07-24 05:42:24 EDT
Created attachment 434122 [details]
File: backtrace
Comment 2 Jiri Popelka 2010-07-26 04:55:41 EDT

*** This bug has been marked as a duplicate of bug 612078 ***
Comment 3 Dirk Foerster 2010-09-12 09:02:26 EDT
Installed Fedora 13 updates. Added local printer. Message informed driver was already installed. Clicked OK. Another message informed system is looking for driver. Waited until that search was finished and then clicked OK. Found driver was displayed next. Clicked OK. Printer is configured now and prints. Issue solved.
Comment 4 Jiri Popelka 2010-09-13 04:35:04 EDT
Thanks for info, but AFAICT this issue is probably some kind of memory corruption which can occur from time to time.

Note You need to log in before you can comment on or make changes to this bug.