Bug 61798 - pico (part of pine package) should be replaced with nano due to licensing
pico (part of pine package) should be replaced with nano due to licensing
Status: CLOSED DUPLICATE of bug 55253
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
http://www.nano-editor.org/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-24 13:50 EST by L. Patrick Smallwood
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L. Patrick Smallwood 2002-03-24 13:50:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
Pico, as part of the pine package is not under a gpl-compliant license. Nano, 
an official GNU project is now a stable, well-tested, well supported, and 
complete drop-in replacement for pico, available under the GPL.

Pico should be replaced with nano, even if it means an additional package 
(which, imho, should be done anyways, you shouldnt have to install a large non-
gpl mail program to get a friendly text-editor).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Examine the license of Pico
2.Examine the license of Nano
3.Compare and contrast
	

Actual Results:  The pico license is not GPL, nor GPL-compatible.

Expected Results:  I expect Redhat packages to generally be GPL if possible. 

Additional info:

http://www.nano-editor.org/overview.html has an overview of the product, and 
http://www.nano-editor.org/dist/v1.0/RPMS/nano-1.0.8-1.src.rpm has a very 
recent src rpm to work from.
Comment 1 Mike A. Harris 2002-03-25 20:11:44 EST
nano is suggested about once each release by someone.  nano, while
similar in functionality to pico, since it clones the UI, etc, is not
a 100% replacement for pico.  There is no way we'll replace pico with
nano, as that will only confuse users.

There are enough editors in the distribution already to choose from.

I agree with you on the license issues, and also that nano is open source,
and thus preferred, however we cant just add software without good reason to
do so.  If a clone of PINE were to come out of the woodwork, and be an
acceptable replacement for PINE, then we could consider this.

I have been directly involved with discussions on the GNU Mana project,
which is a code fork of PINE, however nobody is willing to put forth legal
support to face the UW's bluff of legal threat, so GNU mana remains an
idle dead project.

Ultimately, people will just use PINE because it is there.  There is little
incentive to rewrite it from scratch, so it is unlikely to change in the
future I'm afraid.
Comment 2 Dan Naumov 2002-04-04 11:25:56 EST
Actually, I would agree with the person suggesting the RFE. I too, would like to
see Nano be included with Redhat. Not because of the license issues, but for
another reasons. Nano offers more features then pico does and actually has a
future, seeing as it is under active development. AFAIK, pico is not.
Comment 3 Mike A. Harris 2002-04-04 11:36:55 EST
Well, this bug report is filed against pine, and nano has nothing to do with
pine other than being similar to pico.  As stated above, nano will NOT
replace pico.  Wether or not nano makes it into the distro doesn't have
anything to do with pine ultimately.  As long as pine stays, it stays with
pico.
Comment 4 Mike A. Harris 2003-05-20 03:57:29 EDT

*** This bug has been marked as a duplicate of 55253 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.