Bug 55253 - RFE: Please Include the nano text editor, which is a GPL'd clone of pico
RFE: Please Include the nano text editor, which is a GPL'd clone of pico
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
: FutureFeature
: 61798 87620 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 07:30 EST by Christian Rose
Modified: 2007-04-18 12:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-20 04:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2001-10-28 07:30:12 EST
I'd like to see GNU nano replace the pico editor in the next release.

Nano isn't just free, it's also localized into many languages, something
that pico isn't.
Comment 1 Chris Ricker 2001-10-28 09:02:56 EST
nano doesn't support function keys, which are widely used with pico (pico -f
doesn't have a nano -f equivalent).

I'd prefer pico be kept for that reason....
Comment 2 Mike A. Harris 2001-10-28 17:40:52 EST
There is quite a wealth of different editors available in the
distribution already that support internationalization.  Really,
IMHO, we should remove 10 or so editors rather than add more.  ;o)

If PINE ever is replaced with a true open source clone of PINE,
such as GNU Mana, then Nano can replace PICO at the same time.
Comment 3 Mike A. Harris 2003-05-20 03:57:32 EDT
*** Bug 61798 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2003-05-20 03:58:01 EDT
*** Bug 87620 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2003-05-20 04:02:48 EDT
pine has now officially been removed from Red Hat Linux rawhide development
and will no longer be in future OS products.  As such, we have now begun
including the nano editor as promised above.  ;o)

I have heard rumors of an open source pine clone written from scratch
which will be coming out soon, however it is an unsubstantiated rumor as
of this time.  If it does come out, I will definitely investigate it for
possible future inclusion as well.

Closing as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.