Bug 61815 - Evolution loading looks like a crash
Evolution loading looks like a crash
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-24 15:33 EST by Alan Cox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 19:09:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2002-03-24 15:33:23 EST
I imported my old mailbox into Evolution to play with it - the importer works
beautifully. Unfortunately now Evolution sticks up a plain blue square and thats
basically it. So far it has used over 2.5 minutes of CPU time and nothing has
yet happened. Mutt and Elm take 5s and 1s respectively of CPU time to load the
same mailbox.

It appears that something is very wrong with the performance of the evolution
mail loading - that it loads unconditionally. that it has no cancel button, that
it has no progress bar.

I was under the impression that it had a database system for fast handling of
large mailboxes  ?

Still nothing has happened. There also seems to be no way to get your evolution
back after this situation occurs either.
Comment 1 Jay Turner 2002-03-25 07:42:59 EST
*** Bug 59668 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2002-03-25 18:47:32 EST
Is this reading in an mbox?  If so, how large of one?

Yes, evolution does indexing... sometimes its importers get confused though :(
Comment 3 Alan Cox 2002-03-25 19:09:04 EST
The mailbox is 65,000 messages. The importer handles it beautifully, evolution
takes forever to load it but is snappy once it has (elm by comparison loads it
in 1.5 seconds of CPU time, mutt in 5)

With small mailboxes 1000 or less it seems fine
Comment 4 Alan Cox 2002-03-25 20:21:28 EST
Got a ximian answer. The index was corrupt because I aborted the thing at 60,000
messages, it was reindexing. With the index ok it loads 60,000 messages in about
10 seconds.


Note You need to log in before you can comment on or make changes to this bug.