Bug 618345 - ply-keyboard.c:384 Assertion failed
ply-keyboard.c:384 Assertion failed
Status: CLOSED DUPLICATE of bug 614245
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 13:58 EDT by Thomas Meyer
Modified: 2010-07-27 07:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 07:41:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Meyer 2010-07-26 13:58:54 EDT
Description of problem:

I did install these packages in top of Fedora 13 and booted with "init=/bin/systemd" and I get this message from plymouth in the initram disk:

plymouthd: ply_keyboard.c:384: ply_keyboard_watch_for_input: Assertion 'keyboard != ((void*)0)' failed.

Version-Release number of selected component (if applicable):
-rw-rw-r--. 1 thomas thomas   58628 26. Jul 18:05 libgudev1-160-8.fc14.i686.rpm
-rw-rw-r--. 1 thomas thomas   73608 26. Jul 18:05 libudev-160-8.fc14.i686.rpm
-rw-rw-r--. 1 thomas thomas   65680 26. Jul 18:07 libudev-devel-160-8.fc14.i686.rpm
-rw-rw-r--. 1 thomas thomas  726592 26. Jul 18:03 selinux-policy-3.8.8-3.fc14.noarch.rpm
-rw-rw-r--. 1 thomas thomas 2368296 26. Jul 18:04 selinux-policy-targeted-3.8.8-3.fc14.noarch.rpm
-rw-rw-r--. 1 thomas thomas  367636 26. Jul 17:59 systemd-4-3.fc14.i686.rpm
-rw-rw-r--. 1 thomas thomas   99292 26. Jul 17:59 systemd-units-4-3.fc14.i686.rpm
-rw-rw-r--. 1 thomas thomas  347172 26. Jul 18:05 udev-160-8.fc14.i686.rpm

Name       : plymouth
Architektur : i686
Version    : 0.8.2
Ausgabe    : 3.fc13
Grösse     : 160 k
Repo       : installed
Aus repo    : fedora
Zusammenfassung    : Graphical Boot Animation and Logger
URL        : http://freedesktop.org/software/plymouth/releases
License    : GPLv2+
Beschreibung:Plymouth provides an attractive graphical boot animation in
           : place of the text messages that normally get shown.  Text
           : messages are instead redirected to a log file for viewing
           : after boot.

How reproducible:
always

Steps to Reproduce:
1. Boot system with "init=/bin/systemd"
2.
3.
  
Actual results:
graphical password prompt is aborted. I get dropped back to text password prompt. Entering the password is possible and then the boot process continues.

Expected results:
Plymouth should get it's keyboard and drop me in the graphical password prompt for LUKS.

Additional info:
Comment 1 Michal Schmidt 2010-07-27 07:41:21 EDT

*** This bug has been marked as a duplicate of bug 614245 ***

Note You need to log in before you can comment on or make changes to this bug.