Bug 61842 - No root password dialog when executing programs as a normal user
No root password dialog when executing programs as a normal user
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: usermode (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
: 61909 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-25 00:33 EST by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 03:22:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-25 00:33:45 EST
Description of Problem:

When logging in as a 'normal' user (i.e. NOT root), the applications which are
only executable by root (for example, printer configuration) are still visible
within the menus but not actually accessible. In 7.2 (Enigma), if a normal user
tried to access these programs, a dialog box would pop-up, prompting for roots
password. This does not happen in skipjack-beta1. For a brief moment, a dialog
box flashes on the screen but then disappears (on my system I get to see the
outline of a box before its gone). As a consequence, I end up examining the
icons properties to determine which executable was being accessed, then I bring
up a terminal window, SU to root and execute the file directly.

I have had this happen on two successive fresh installations.


Version-Release number of selected component (if applicable):

Skipjack-beta1.

How Reproducible:

Happens all the time.


Steps to Reproduce:
1. Try to execute an application requiring root privilage as a normal user.
2. 
3. 

Actual Results:

A dialog box (of unknown content) flashes for a moment on the screen. The
intended application fails to launch.


Expected Results:

A prompt for roots password followed by the launch of the application is successful.

Additional Information:
	
AMD Duron 1.0 Ghz, 256MB RAM, Nvidia2 Generic card, no other OS on this machine.
Comment 1 Havoc Pennington 2002-03-25 09:44:05 EST
Presumably a usermode problem, but very important to fix
Comment 2 Adrian Likins 2002-03-26 13:49:11 EST
*** Bug 61909 has been marked as a duplicate of this bug. ***
Comment 3 Bill Crawford 2002-03-27 03:21:55 EST
This is probably the "usermode-gtk doesn't depend on pygtk2 or pygtk2-libglade"
bug ... also some people have reported not getting usermode-gtk installed at
all.
Comment 4 Nalin Dahyabhai 2002-03-28 17:01:08 EST
In Skipjack, usermode-gtk wasn't listed in the right parts of the comps file,
and wasn't being installed.  This is fixed in the development tree (all
installations with X, save for the "Classic X" package set, include usermode-gtk
now).  Marking as fixed in Raw Hide due to a lack of a "fixed in development
tree" resolution.

Note You need to log in before you can comment on or make changes to this bug.