Bug 61909 - rhn_register non-root in X lacks X password dialogue
rhn_register non-root in X lacks X password dialogue
Status: CLOSED DUPLICATE of bug 61842
Product: Red Hat Public Beta
Classification: Retired
Component: rhn_register (Show other bugs)
skipjack-beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-25 17:04 EST by Warren Togami
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 11:51:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-03-25 17:04:00 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/2.99 (3.0 rc3); Linux) 
 
Description of problem: 
When you run rhn_register as a non-root user in X nothing happens.  When you run it in a 
console it asks for root password in order to procede, but you cannot see this console 
password prompt if you run rhn_register from a menu. 
 
Version-Release number of selected component (if applicable): 
Red Hat Skipjack Beta1 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Login as non-root user. 
2. Run rhn_register from KDE or Gnome menu. 
3. Application feedback but no rhn_register. 
 
Expected Results: 
Pop-up password dialogue to enter root password.
Comment 1 Adrian Likins 2002-03-25 17:30:29 EST
I need more info...

what happens when you run (from X, as a non-root user)

rhn_register

and:

/usr/sbin/rhn_register

Comment 2 Warren Togami 2002-03-25 17:43:50 EST
Interesting... 3 different behaviors
(logged into KDE as non-root user)

1. Running rhn_register from KDE menu.
Result:
KDE Application startup feedback.  Nothing else.

2. Running "rhn_register" from KDE console.
Result:
Console prompt "Password:".  If I type root password it works.

3. Running "/usr/sbin/rhn_register" from KDE console.
Console message "warning: can't access /etc/sysconfig/rhn/rhn_register"
Pop-up "Error" window saying "You must run the RHN Registration Client as root."
Comment 3 Adrian Likins 2002-03-25 18:05:13 EST
okay, #2 and #3 are basically working correctly (#2 is what the
typically user sees, since they are running /usr/bin/rhn_register
which invokes consolehelper, the app that actually asks for your
passwd)

#3 is running it directly, and it telling you it needs to be root.

#1 is uhmm, dunno yet...

Can you try running, from a console:

/usr/share/rhn/rhn_icon_helper


Comment 4 Warren Togami 2002-03-25 18:21:02 EST
Run /usr/share/rhn/rhn_icon_helper from the KDE console.  It behaves just like
#2  rhn_register asking for a "Password:" at the console then runs up2date as root.

It appears that up2date has the exact same problem as rhn_register.  This is
mainly a problem if people run rhn_register or up2date from the KDE menus.
Comment 5 Adrian Likins 2002-03-25 18:26:04 EST
Hmm, very odd. At the moment, I'm not sure what would be
causing the problem you describe. It should just be executing
the apps as described by the .desktop files, which look
to be okay. 

I'll attempt to replicate this on a beta box and see if
I can track down whats going on.
Comment 6 Adrian Likins 2002-03-26 13:49:16 EST
This seems to be the same issue as bug #61842, it's
a consolehelper issue. 

I'm going to close this as a dup of that bug since
it's actually a consolehelper bug.

*** This bug has been marked as a duplicate of 61842 ***

Note You need to log in before you can comment on or make changes to this bug.