Bug 618425 - Gwibber won't quit!
Gwibber won't quit!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gwibber (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 619177 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 18:06 EDT by eric@christensenplace.us
Modified: 2010-08-19 22:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: gwibber-2.31.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 21:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2010-07-26 18:06:51 EDT
Description of problem: I cannot get Gwibber to quit.  When selecting Quit on the Gwibber icon on the menu bar nothing happens.  (see additional comments)


Version-Release number of selected component (if applicable): gwibber-2.31.2-7.fc13.noarch


How reproducible: Always, so far.


Steps to Reproduce:
1. Start Gwibber
2. Attempt to close Gwibber
3.
  
Actual results:
Won't quit.


Expected results:
Quits


Additional info:

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gwibber/client.py", line 344, in on_quit
    self.service.Quit()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Comment 1 eric@christensenplace.us 2010-07-26 22:44:29 EDT
I think I see what's happening...

If you have selected "Minimize to tray on close" then it will never close even when selecting "quit" from the tray icon.
Comment 2 Tom "spot" Callaway 2010-07-27 08:27:16 EDT
Yep, that's what's happening.

def on_window_close(self, *args):
    if self.model.settings["minimize_to_tray"]:
      self.on_toggle_window_visibility(self)
      return True

So, basically, the Quit option from the tray icon is looping back to the "on_window_close" function and since minimize_to_tray is set to true, the client toggles back to "visible".

Doesn't traceback for me, but it doesn't quit either.

I'll think about how to handle this.
Comment 3 Tom "spot" Callaway 2010-07-29 13:49:47 EDT
*** Bug 619177 has been marked as a duplicate of this bug. ***
Comment 4 Tom "spot" Callaway 2010-08-09 14:03:58 EDT
Okay, here's how I've "fixed" this issue.

If the client is not minimized, selecting "Quit" (either from the icon or the client window) will minimize to the tray icon.

If the client _is_ minimized, and you select "Quit" from the tray icon, it will now quit.

Breaks the loop, although, it admittedly isn't very clear.
Comment 5 Fedora Update System 2010-08-09 16:24:58 EDT
gwibber-2.31.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc12
Comment 6 Fedora Update System 2010-08-09 16:29:51 EDT
gwibber-2.31.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc13
Comment 7 Fedora Update System 2010-08-10 17:26:55 EDT
gwibber-2.31.4-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc12
Comment 8 Fedora Update System 2010-08-10 17:32:22 EDT
gwibber-2.31.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc13
Comment 9 Fedora Update System 2010-08-19 21:49:28 EDT
gwibber-2.31.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-08-19 22:03:45 EDT
gwibber-2.31.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.