Bug 618678 - powers off instead of reboot
powers off instead of reboot
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 620290 (view as bug list)
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-07-27 10:24 EDT by Michal Schmidt
Modified: 2010-08-05 13:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 13:50:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
systemctl: ignore "-p" when called as "reboot" (700 bytes, patch)
2010-07-30 11:29 EDT, Michal Schmidt
no flags Details | Diff

  None (edit)
Description Michal Schmidt 2010-07-27 10:24:25 EDT
Description of problem:
Trying to reboot in any of the usual ways (CTRL+ALT+DEL, init 6, "Restart" from gdm) results in a power-off instead.

It turns out that /etc/init.d/halt passes a "-p" parameter to /sbin/reboot (a symlink to systemctl) and unlike upstart, systemd does not ignore it in this case.

Version-Release number of selected component (if applicable):
systemd-sysvinit-4-3.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. Have upstart-sysvinit installed.
2. Run "reboot -f -p". Notice it causes a reboot, "-p" is correctly ignored.
3. Uninstall upstart-sysvinit, install systemd-sysvinit instead.
4. Run "reboot -f -p".
  
Actual results:
It powers off instead of reboot.

Expected results:
The "-p" parameter should be ignored when systemctl is invoked as "reboot".
Comment 1 James Laska 2010-07-29 13:57:02 EDT
Adding to F14Beta blocker list per the following Beta release criteria (https://fedoraproject.org/wiki/Fedora_14_Beta_Release_Criteria)

  "The desktop's offered mechanisms for shutting down, logging out
   and rebooting must work "
Comment 2 Bug Zapper 2010-07-30 08:53:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Michal Schmidt 2010-07-30 11:29:33 EDT
Created attachment 435583 [details]
systemctl: ignore "-p" when called as "reboot"
Comment 4 Michal Schmidt 2010-08-05 07:40:42 EDT
*** Bug 620290 has been marked as a duplicate of this bug. ***
Comment 5 Lennart Poettering 2010-08-05 13:50:09 EDT
Fix merged upstream.

Michal, thanks for the patch! Much appreciated!

Note You need to log in before you can comment on or make changes to this bug.