Bug 620290 - systemd on upgraded system doesn't reboot properly
systemd on upgraded system doesn't reboot properly
Status: CLOSED DUPLICATE of bug 618678
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-01 22:00 EDT by Kevin Fenzi
Modified: 2010-08-05 07:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 07:40:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2010-08-01 22:00:03 EDT
I'm not sure there is any easy way to fix this, but it would be nice if there was: 

Take a f13 machine or a rawhide machine that was/is using upstart. 

Upgrade it. It gets systemd and the systemd-sysvinit packages fine. 

Try and reboot/shutdown -r and it hangs. This is likely due to upstart still being used for the current boot. 
Could the systemd versions of those commands use some backward compat way of messaging to upstart to get the job done?
Comment 1 Michal Schmidt 2010-08-02 07:51:07 EDT
(In reply to comment #0)
> This is likely due to upstart still being used for the current boot.

I'm not so sure that's the real reason. Even after booting with init=/sbin/upstart and having systemd-sysvinit installed (which provides reboot, shutdown, etc.) I can still shutdown the system. When trying to reboot I hit bug 618678, but no hang.

> Could the systemd versions of those commands use some backward compat way
> of messaging to upstart to get the job done?

AFAICT, the necessary compatibility is there. See Lennart's message: http://lists.fedoraproject.org/pipermail/devel/2010-July/138921.html

The hang you're seeing may be caused by something different. What's the last message you get?
Comment 2 Kevin Fenzi 2010-08-04 18:44:38 EDT
It seems to be halting instead of rebooting: 

mount: / is busy
mount: mount point /var/tmp/imgcreate-ySKuLQ/install_root/sys does not exist
mount: mount point /var/tmp/imgcreate-ySKuLQ/install_root/proc does not exist
mount: mount point /var/tmp/imgcreate-ySKuLQ/install_root/dev/pts does not exist
mount: mount point /var/tmp/imgcreate-ySKuLQ/install_root/dev/shm does not exist
mount: mount point /var/tmp/imgcreate-ySKuLQ/install_root/var/cache/yum does not exist
Please stand by while rebooting the system...
Powering off
System halted.

(The /var/tmp things there might be some old livecd-creator bind mounts).
Comment 3 Michal Schmidt 2010-08-05 07:40:42 EDT
Power off or halt instead of reboot is bug 618678.

*** This bug has been marked as a duplicate of bug 618678 ***

Note You need to log in before you can comment on or make changes to this bug.